Home        Store        Docs        Blog

Cannot connect ping sonar to macbook pro

Hello all,

I’ve been trying all day to connect the ping sonar to pingviewer on a macbook pro running high sierra 10.13.6. My ardusub version is 0.0.18 and according to the documentation everything seems to be in order but i still cannot get a connection. I also tried on my windows 10 machine and still nothing. I am using the bluart usb to serial adapter and i’m starting to suspect thats where the problem might be. i notice there are 3 leds on the board, one for power, one for tx and one for rx. When the ping sounder is connected only the power led comes on, i’ve tried with 4 different micro usb cables and no other leds come on. I’m sure all my connections are correct, as i’ve triple check them…does anybody have any idea what might be going on? could it a faulty bluart adapter?
Thanks for you time guys and gals.
William

Hi @williamn, I’m sorry you are having trouble.

If you haven’t already, you should try connecting the ping sonar directly to your macbook.

When you do, what does the device manager page look like in ping viewer? (please share a screenshot).

Goodevening Jacob,
I’ve already tried that this afternoon. The sonar doesn’t show up in ping viewer on my mac or my windows 10 machine.
William

Hi,

Can you open the sensor and make sure that the LED is blinking ?
Take a look in this device recovery guide.

Hi @williamn, there are some other things you can make sure are working too:

  • check that the usb-uart bridge is working with your computer. The list of communication ports should change when you plug/unplug your device.

    • on windows: check the COM port list in the windows device manager
    • on mac: check the serial devices list when you enter the command ls /dev/tty.usb* in the terminal
  • check that the 5V, ground, RX and TX lines are connected correctly to the device. Try switching the RX and TX lines.

Try also the troubleshooting steps here: https://docs.bluerobotics.com/ping-viewer/faq-and-troubleshooting/