Ping Sonar Connection


I am trying to connect my Ping sonar altimeter to the ping viewer on my Ubuntu laptop. However, I did not see any usb device connected when I plug the usb cable from the usb-uart converter. There is no usb device connected when I run dmesg.

Both LEDs on the usb-uart converter and the one inside the ping sonar are flashing when the USB cable is connected. I believe this means the sonar is powered on. I also tried to switch Tx and Rx but the device is still not recognized.

What might be the problem causing the connection problem then?

Thank you,

Hi @philip-huang,

I asked the software team about this and got two suggestions:

  1. your USB cable may be “power only” (i.e. it may not support data transfer)
    • try using a different cable, preferably one which you know works for transferring data
  2. your computer may have an application running that takes over serial devices without regard for other applications that may be trying to use them. ModemManager and brltty have both been known to cause issues like that, at least for ArduPilot flight controllers.
    • it may help to uninstall those applications, if they’re on your computer

Not sure if PingViewer scans all the potential serial ports. I’d be curious to know if SonarView finds your Ping sonar. Its a free download and easy Linux install.

Hi @ljlukis,

Ping Viewer is an open source program. The serial port scanning code can be found here, and uses Qt’s QSerialPortInfo::availablePorts to determine any serial ports on the system that are available for connecting to :slight_smile:

1 Like

Hi Eliot,

Indeed, the problem is my USB cable. I switched to a different cable and my computer can identify the USB now.


1 Like