Home        Store        Docs        Blog

Ping Viewer - Serial Port permission error

Hello,

I’m trying to connect a Ping sonar with the Ping Viewer app.
When I open the application (in administrator mode), I have the message ‘No device detected’.
I click on Manual connection, the parameters are well informed

I click on Connect.

I do not have anything in the window, and In the configuration menu, the information is not filled
when I look at the log files, I have error messages concerning the opening of the serial ports:

(see 18:01:14:654)

In my firewall, I created a rule to allow the ping viewer application to communicate to all PCs, through all ports.
I work under Windows 10.
What’s the problem?

Thanks for your help,
Best Regards,

Nicolas

Hi,

If you are running Ping-Viewer as admin and you are facing PermissionError message, it means that a second application is blocking the access or the device COM5 is a system serial port and not your FTDI device (you can check that via device manager).

When I connect the ping to the USB port, in the device manager, I have:

image

So it seems that the USB port is correct.
How can I detect which application is blocking the USB port?

Regards,

Hi,

In your last picture, please go under the serial device Properties -> Details -> Property -> Service and provide the value of this property.

Remember that programs like putty or anything that can check the serial port can block it for others programs.

I do not use putty.
I tried disabling the firewall, but I have the same result

Hi,

It appears to be correct, did you try it with a different computer ?
Are you using Blue Robotics BLUEART adapter or a different one ? Have you checked if the RX/TX connection is correct ?
Ping-Viewer should probe and detect any sensor in your computer without further modifications from a default windows installation and with the connect wire.

Yes I’m using Blue Robotics BLUEART and I checked RX/TX connection with Hyperterminal software, and it’s OK.
I do not have another pc under windows 10

I connect my Blueart on COM5 serial port.
If I execute stm32flash command, I have the result :

what is interface serial_w32?

Hi,

It appears that there is something wrong in your windows, to test it, you can try to install the Arduino software or any serial monitor around (like putty) and do the following:

  1. Connect BLUART in your computer
  2. Short serial TX and RX
  3. Open the serial monitor
    In arduino: Go in tools -> select the serial port -> tools -> Serial monitor.
    Try to write something and click in send
  4. If you are unable to receive what you are sending, I would recommend to install the FTDI driver and restart your computer.
  5. If that does not helps, check if the hardware is working in a different computer, in a fresh windows install, and with a different serial USB adapter.

@AWDRONE,

Can you also try to set your serial port to default settings ?

Hi,

I tried that but no results.
I am using version 2.0.4 of Ping viewer.
Maybe I can try with an older version? Where can I find older versions of the Ping Viewer app?

Best Regards,

Hi,

You can check all available releases here: https://github.com/bluerobotics/ping-viewer/releases

Hi,

When I execute the command :
.\stm32flash.exe -v -g 0x0 -b 115200 -w .\Ping_V3.26_115kb.hex COM3
(see page https://docs.bluerobotics.com/ping-viewer/firmware-update/)

I have the error message :

stm32flash 0.5

http://stm32flash.sourceforge.net/

Using Parser : Intel HEX
Interface serial_w32: 115200 8E1
Failed to init device.

I found discussions where it is mentioned that the executable stm32flash can have problems under windows.
(see :
https://onstep.groups.io/g/main/topic/failed_to_init_device/25067573?p=Created,,,20,1,0,0
http://stm32duinoforum.com/forum/viewtopic_f_20_t_2569.html
)

How can I resolve that?

Best Regards,

Hi,

@AWDRONE problem was fixed with the device recovery procedure.
After opening the sensor, make sure that the sensor does have a blinking LED in the main board, otherwise it’s necessary to follow the device recovery instructions.

Hi,

It work when the ping is plugged directly on the pc, but if I plug the ping on the pixawk and the fxti plugged on the pc, it doesn’t work :

no device detected, and if i try a manual connection, there is no choice in the Serial Port list.

Hi,

You are not supposed to connect Ping1D in the pixhawk but in companion. please follow our integration guide.

Hi,
Sorry, I would say companion, pixhawk has no usb connector.

Hi,

Which version of companion are you running ?
Please follow the software update section under the integration guide for Ping1D.
Remember to restart companion after the update.

Hi,

companion version 0.0.17
I plugged Ping on the usb the usb port located under the auxiliary ports of the pixhawk (there is no other usb port)

Hi,

Please update to the last companion version 0.0.18 and restart.