Home        Store        Learn        Blog

Ping 1D not working

Hi,
I have a BlueRov2 with a Ping Sonar (1D) and I’m having trouble to get it running smoothly over the companion.
What I’ve tried:

  1. I connected the Ping to the USB-TTL converter and plugged that via micro USB to my PC. Started PingViewer v2.04. It detected the COM port and then runs smoothly. I can see the waterfall diagramm running … all fine.
  2. I hook up the USB-TTL to the companion. Via webui I configure the two endpoints:
  • serial, baudrate 115200, /dev/serial/by-id/usb-FTDI_FT231…
  • udp, IP address: 0.0.0.0, port: 1234
    So far so good. Then I set up the bridge (bi-directional) - all looks good. The serial endpoint has the IP as the outgoing connection and the IP has the serial as the outgoing connection.
    Now I start PingViewer and go for a manual connection:
    I choose UDP, IP 192.168.2.2, Port 1234
    The USB-TTL converter shows some “traffic” on the serial line as the TX and RX leds are blinking (1Hz maybe). In the base data panel in PingViewer it shows me some RX packets, incrementing around every second and it’s updating the processor temperature and the PCB temperature and the Board voltage values.

The I started playing a bit with the ports and got it eventually “running” - the white LEDs on the USB-TTL blinks rapidly and I can see the waterfall diagramm “moving” for a couple of seconds. Then the diagramm stops. No more values are updated, but the white LEDs is still blinking rapidly.

I then checked with Wireshark the local network traffic:
Mavlink and video messages are still coming through, but nothing on the “sonar” ports …

Any ideas what I’m doing wrong?
Can I check on the companion directly via ssh if the bridge is configured correctly and that the data is routed?

Any help is highly appreciated …
Thanks and greetings from Germany,
Mike

PS:
Companion version at first was 0.0.18. I just updated to 0.0.19. Same behavior.
Also disabled the firewall … no blocking there …

No endpoint is necessary, Ping is plug & play in companion.
Please delete your endpoint and restart companion.

Hi Patrick,
Thanks for your reply!
Classical overthinking on my part :wink:
Greetings,
Mike

Hi Mike,

I hope that ping is working for you, let us know if you need any further help.

Hi Patrick,

works like a charm - thanks!
I appreciate your help!

best regards,
Mike

This topic was automatically closed after 2 days. New replies are no longer allowed.