No video Qgroundcontrol 4.1.1 on Mac

I can’t seem to get the video from my BlueROV 2 Heavy (Ardusub version 4.0.2) showing in QGC ver 4.1.1: all it says is “Waiting for video”. However, the video stream did show up fine in QGC 3.5.6 (also with Ardusub 4.0.2).

I’ve tried:

  • Reinstalling QGC
  • Downloading new gstreamer dependencies (Video Stream Does Not Working)
  • Resetting application access to camera (Mac privacy-settings): QGC 3.5.6 asked permission to use the camera every time it started, so far 4.1.1 hasn’t asked (and I’m not sure if the camera access is for the built in webcam only).
  • Removing QGC 3.5.6 completely from the mac, restarted, installed QGC 4.1.1 from scratch, but still no luck.

I have two options:

  • Get video from the pilot camera to work with 4.1.1
    - Get hold of a copy of QGC 3.5.6 for again edit: found relevant release on github.

… neither of which I’m able to.

Does anyone have any helpful ideas?

The mac is a 2013 Macbook pro, running Mojave, ver 10.14.6.

I just upgraded to 4.1.1 on my new MacBook Pro, and I have the same issue, was working fine on the 3.5.6, I thought that it was maybe the new M1 processor, but if you have the same issue with an older PowerBook I guess we still need to look for answers.

Well, at least that means I’m not alone, though I’m sorry to hear you’re having the same problem.

I ran the ROV yesterday with QGC 3.5.6, with the usual random crashes (program quits) I’ve always experienced with that version. However, what I saw of QGC 4.X before downgrading again looked nice, so finding a solution to this problem would be preferable.

Which Mac OS version do you run, @Blacklab?

Yes same here, the improvement seamed really nice, but with no video its a big issue :wink: I run the Big Sure version 11.2, on a M1 PowerBook Pro. The older version Version of QGC was working nice on it.
I had purchased the Nimbus+ controller as it wasc supposed to be more compatible with a mac, but was never able to connect it to QGC, I thought that could have been fixed in the 4 version but no, So I moved back the the Xbox one controller.

I hope we find a solution soon.


@Skredfare I re-downloaded the QGC today cause I saw that they put the 4.0.5 and not the 4.1.1, and this version works great as the video feed, did not have to downgrade my firmware for Ardusub. You should maybe try that version. It did work for me.
Have a good weekend


1 Like

Thanks for the tip, Denis! I’ve found the 4.0.5 version now, and will test it out later.

yes, I’ve the same problem with QGC 4.4.4 working under Linux Mint. I kept my QGC v4.0.5 (both as appimages) as it worked okay with it, (except I couldnt record using QGC).
seems QGC v4.1.1 was released a bit too early

Hi there,
I am irritated… are you working with the drone-versions of QGC? I have installed 4.0.8 and this seems to be the latest version with the ardusub user interface for the ROV. When I download the version 4.1.1 that is provided on then it has not the user interface for ROV operations but on the bottom telemetry data for drone flights. Even when the ROV is connected and chosen after the new install. I like the big record button on the main screen but all the telemetry data (depth, temperature, tether turns…) are not displayed in that 4.1.1 so it is unusable for ROV
Why/how do you work with that?



I am facing the same problem as you guys. The thing is I don’t have version 4.0.5, could you give me the link where to find it please ? thx eric

1 Like

It seems I brought the problems on myself when I downloaded the last version directly from the QG website: apparently a much safer way of doing it is to actually download the QG version that’s actually supported by BlueROV2 from Blue Robotic’s own website Downloads

It’s a slight case of “read the manual, please” (to put it nicely), I guess. :man_shrugging:


Sorry for the trouble, but indeed 4.1.1 has a problem for Mac OS related to the deployment, should be fixed soon, meanwhile it’s necessary to use the download link provided in our documentation.
It’s possible to check the issue status here:

4 posts were merged into an existing topic: QGC version 4.1.1 camera recording issues