QGC version 4.1.1 camera recording issues

I’ve recently got a BlueROV2 and got it mostly working, except video. The Video streams fine to QGC but when I press the red video icon on the RHS Video Stream box it goes to a pulsating gray colour and that’s it. I have to disable the video stream to get video back as clicking on the grayed out video icon achieves nothing. Their is a file in the QGC video video folder but its empty.
iv gone through the previous topics but haven’t seen anything like this

1 Like


It appears that 4.1.1 is creating the video file under:
Documents\QGroundControl Daily\Video
and not in:

Can you confirm if that is what is happening for you ?

Hi Patrick,
screen shot of /home/brendan/Documents/QGroundControl/Video under v 4.0.5

under v 4.1.1 I dont get video or even the small box on the RHS to toggle video on or off or to record so it dosnt get the chance to generate a new video file

also got two streams running on ports 5600 and 2000 but when i try to run v4.0.5 and VLC on port 2000 a few seconds when QGC starts streaming it shuts down on VLC. im running Linux Mint 19.3 on a MacBookPro9,2 v: 1.0 with a Intel Core i5-3210M. is processing power a problem?

Hi @Brendan_Cooney,

Please test your streams first via VLC if possible, you can test the BlueROV stream in VLC:
To receive the video video from companion, it’s necessary to go in: MediaOpen Network Streamhttp://

You can download and edit the file for your others streams

thanks Patrick, that works well as i have a stream to QGC V4.0.5 and on port 2000 to VLC. Also got VLC recording as still haven’t found what gives with the record button in QGC, V4.05, just have to figure if i can incorporate the SAA file on it as the depth etc can be useful.
Still no video on V4.1.1 but video streams fine to VLC so i’ll stick with the older version for the moment as i just cant give any more time to trying to figure it out.


Hi Brendan,

The latest V4.1.1 has a new option for hardware decode options under video settings in the main settings of QGC, can you try the others options that are available ? Can you confirm that “default” is the one selected ?

yes video decode priority is set to default.
below is some of the console log. for some reason its streaming

Try to change to other than default and see if that helps after restarting QGC.

tried all 4 settings in that tab but no success.
I’ll delete QGC in the next few days and reinstall v4.1.1 but at least i have the older version working with VLC and can now record video which is great. Work for a gov agency and got funding last year to do a marine invasive species survey of our coastline, ports and harbours and this was purchased as part of that and this year will be resurveying as well as planning on mapping marine macrophytes along the coastline

Hi @Brendan_Cooney,

From your screenshot it appears that you are under Linux, since VA-API setting is a linux decoder, how did you get QGC for it ? The 4.1.1 is only available for Windows. If you are compiling from the source, you’ll need the latest gstreamer 1.18 version.

from here. link is Download and Install · QGroundControl User Guide

version 4.1.1 is available as an appimage.
maybe that is the reason for Ryans problems also.

would you have an apt command for the installation of the list of the files and dependencies for Gstreamer 1.18? If so i’ll run it and see how QGC4.1.1 goes then.
thanks for your help so far!!

Hi there,
version 4.0.8 does not generate video files too, even when the record button was activated. I will switch back to 4.0.5 where the compass is spinning around continously all the time. Dont know whats more bad for operation… :confused:

Hi @schleitauche,

Sorry if you are having problems, but 4.1.1 should work.

If someone is using Mac OS, it appears that 4.1.1 has a deployment problem, we are going to fix that soon:
To track the MacOS problem status:

no, not just Mac, but also linux.

Hi @Brendan_Cooney,

I and others were unable to replicate your problem under linux. From your previous report, you are using Linux mint right ? Are you running inside a VM or do you have a dualboot ? For VM I would recommend to check the settings and see if everything is configured correctly, as hardware instructions, network configuration and etc.

Hi Patrick, no its a fairly clean install of mint (little to no tinkering under the hood), no dual boot or VM. Video seems to work well with V4.0.5, except no recording but I’ve put in place the second video stream to VLC and I can record from that so that’ll keep me going for the moment. I looked at installing gsteamer 1.18 as you suggested but their was a lot of dependencies and “makes” !

Hi @Brendan_Cooney, if you want to try, I would recommend to install ubuntu 20.10 or any distro based over it, since it comes with gstreamer 1.18