Home        Store        Learn        Blog

Video feed not working on laptop

My lap top was running slow so i put it to computer shop and had to all wiped and reinstalled windows 10, then I reinstalled Qgroundcontrol (ardusub V3.5.4) and all the necessary actions, 192.168.2.1 firewalls etc

Connection , all control , camera up/ down gain , lights etc working no problems

set camera feed to UPD h.264, 5600, but only get …waiting for video feed

The video stream is working on my spare computer as per normal so the issue is with my laptop not the ROV , should i install any video streaming app/program or any other ideas to assist me in my plight ?

Hi @Mac1.

What QGC version are you running? What IP address is your network interface set to?

hello willian
I just downloaded from your website today , i thought V3.5.4 was the QGC version i download (if not where do i see/find what version it is ?)
Is 192.168.2.1 not the correct IP address for the network interface Ethernet connection ?

I followed all the download instruction , I had everything running before on the laptop but it was very slow so i asked my local computer tec to clean it all up and re install windows 10 software , so that i could start from scratch , on my spare laptop it downloaded directly with no issues

thanks appreciate

QGC is actually at 4.0.8 now, while ArduSub is 4.0.1.
You can download latest QGC here.

I have seems some cases of windows blocking QGC ports too.
You can use the Windows 10 Resource Monitor in the network tab to check if windows is blocking listening ports for QGroundControl.exe (UDP port 5600)

Hello Willian
deleted/uninstalled all old QGC downloads and drivers , then downloaded QGC as suggested , checked resource monitor and Qgroundcontrol exe showing,listening ports : PID = 1580, Address = IPv4 unspecific , Port = 14550, protocall UDP and firewall allowed .
should i change port to 5600? if yes how do i go about doing that ?
thanks appreciate

Hi,

Make sure that QGC is set up to receive video via UDP at port 5600
Screenshot from 2020-07-03 17-29-46

And then check the resource monitor network tab. First filter for QGroundControl.exe (1), then go to the Listening ports section (2), and then find UDP port 5600 (3)

Hello Willian,
camera was set as suggested, QGC in first filter was ticked but unable to find UDP port 5600, only port as mentioned already for QGC exe was UDP port 14550 (which was showing allowed )
maybe next week (monday) would you be able to do a remote access on my laptop and correct the settings for me ? i have spent the last 8 hrs and still unable to source the video feed, i will keep trying over the weekend and see if i have any success , but if not would the remote access be possible on monday ?

thanks

Hello Willian,
I managed to finally get it working , uninstalled everything and re installed again and it cleared things and i was able to get video feed ok
thanks for your assistance

1 Like