Home        Store        Docs        Blog

No telemetry 2.0

Greetings

I have some problems with the pixhawk. Ive followed the Ardusub troubleshoot and the raspberry trouble shoot and cant seem to make it work.
A few images:

any ideas?

after some more tries ive found the pixhawk will communicate with Qground and light up all its leds when using the “PX 4 flight stack v 1.9.0 stable release”
Tried a new flash card with 32gb.
Updated Qground and manually
tried to manually install the ardusub V2 and V3 px4 files from the system page

when i place any of the other images, ardurover, arduplane on for both ChibiOS and NuttX options in Qground i get some communication, all exept Ardusub.

when flashing the ardusub file in Qground the flashlights in the ROV tickle indefinitely until i disconnect the pixhawk from the computer.

Any clues? am i missing info that could help?

Hello,

Do you get no telemetry via USB as well?
What is the main led doing?

No telemetry or main (big heartbeat led I assume) led activity. In any ardusub image. Only when installing the flightstack 1.9.0 stable. Do I get both, this is directly connecting the usb to the computer.
When going trough the raspberry the pix is recognized and the Mavlink is marked active. But no ardusub version is detected. Even when successfully installed.

Thanks.

Hello, There is often some confusion regarding the SD cards.
The SD card of the Pixhawk and format with a Fat32 filesystem.
The SD card at the companion should have the latest companion image

IF I’m not mistaken, PX4 and some of the other vehicles are able to work without a SD card, which explains the symptoms you are seeing.

Hi thanks for the follow up.

-The SD card in the Raspberry has the latest companion image. 0.0.17
-The SD in the Pix has been formatted as Fat32
-Ive tried to flash the Pix trough the Raspberry system page with this results:
-Download and update/Stable : its marked as complete but after a full reboot the system page still shows a “ArduSub version: not found” and there is no telemetry or connection on Qground
-Updated the Firmware trough Qground control with direct usb connection. And with all of the present options, there is still no recognized ardusub version detected, or communication with Qground.

The only instance where i get any feedback from the pix, while still directly connected to the computer trough USB, is when installing the firmware update “Px 4 flight stack v 1.9.0 stable release” from the Qground control. then it connects to the Pixhawk and ask for air frame config, sensors, rc etc… But even with this firmware, when i plug the pix to the raspberry, there is no response in Qground.

Thanks and let me know if i missed anything.

I advise you to get it working with QGC via USB first.
Try this:

  1. Get the old sd card, format that as Fat32, and use that for the Pixhawk. Not all SD cards are supported and the larger the card, the most likely that it might not work, 32Gb is the very upper limit of what the Pixhawk can work with.

  2. Plug the Pixhawk to the PC and flash the firmware for a different vehicle, copter/plane/rover (this will force reset all parameters)

  3. See if that other vehicle is able to communicate Ok with QGC

  4. Flash Ardusub Stable back, test if that communicates with QGC

Done

1-Ive changed the flash card to a 8gb one, formatted as fat32.

2,3-Changed the firmware to that of other vehicles (Various) there is communication with Qground marking errors in the type of airframe and others.

4-When changing back to the Ardusub stable, there is no communication still.

thanks lemme know if you need more info.

Just to make sure, you flashed Ardupilot vehicles, right?

It still looks like an issue with the sd card. Two more tests:

  • After running another vehicle (Arducopter, for instance), check the content on the sd card. There should be a log file in there if it is working ok.

  • Flash ArduSub 3.6.0-Beta to test. It works without an SD card (but is not stable!)

Yes indeed ardupilot ones.

–Ill check the SD after that

– I tried the Beta, but left the SD inside. Ill try it without. Later today.

Thanks.

1 Like

Where did you purchase the pixhawk, and the SD card?

Hi, @jwalser both are the original ones i got from you guys at BlueRobotics.

And @williangalvani The ArduSub 3.6.0-Beta did the following:


It still doesnt connect to the Qground and the heartbeat led isnt active, And the lights on the ROV keep flashing, intermitently.

Is that the large RGB LED? Which colors?

Did you get to check the contents of the sd card?

bootlog.txt (844 Bytes)

That came up with the arducopter one firmware trough Qgroundcontrol

The bootlog file with the Ardusub Beta build firmware, only said
“PX4IO update failed PX4IO not found” also a .bak

And not the leds. the Flashlights in front of the ROV (Lumen Subsea Lights) keep flickering. with the ardusub firmware, both beta and stable.

Thanks.

image

This indicates that the bootloader is running, but not the main application. The bootloader verifies the firmware on the coprocessor and re-programs it if necessary. In older versions (ardusub 3.5), the bootloader also did some verifications of the sd card. If there is an error in one of these processes, the main application may not start. The main led blinking indicates the main application is running.

This combined with the considerations in my last post indicates a hardware failure, or a rare software error. In either event, I think you are due a replacement. Please contact support@bluerobotics.com.

I have one last thing I’m wondering, what does ArduSub master (3.7.0-dev) do?

Same thing. not recognized by system page or Qground control.

Thanks. I think a replacement will be the only way out.