Home        Store        Docs        Blog

No communication with waterlink via integration

Hello BlueRobotics!

I’ve just bought the Waterlinked GPS with the A1 transponder and the BlueROV integration pack. I’m having some problems getting it running via the FXTI.

I can’t access 192.168.2.94 via the FXTI and I can’t ping it in cmd (Destination host unreachable). I do have static IP 192.168.2.1 as per the BlueROV guide. There are no issues at all with connecting and using the BlueROV though.

If I bypass the FXTI and connect with ethernet (IP 192.168.2.50 on that network card), there are no problems with connecting to the Waterlinked system on 192.168.294.

In the waterlinked topside, when booted up, the only LED on the FTXI unit in the topside is power, no link or anything else, do not know if that matters.

I’ve checked continuity with a multimeter without finding any poor connections:

Blue+white connected to FTXI chip in waterlinked topside to Blue+white in the FXTI where I have the tether.

Green+white in ROV bottle to green+white on A1 slot in waterlinked topside.

I’m using channel 6 for red+black between FXTI and waterlinked inside the topside.

I’ve updated to v2.5 on waterlinked.

I’ve looked on this fix: https://github.com/bluerobotics/companion/issues/265 but as it isn’t when I’m booting up QGC, it doesn’t seem to apply in this case.

I have 2 laptops for BlueROV and it is the same on both of them.

Many thanks,

Linus

I’ve also tried both the old and the new interconnection cable, same result.

Thanks,
Linus

@Linus_OD Thank you for the picture that is most helpful!

So I was looking at all the indicator lights and noticed that the “LINK” light is not on the Fathom-X in your box. Upon closer inspection, it appears you are missing the LX200V20 Homeplug Module that plugs into the Fathom-X board. This is why you weren’t getting a connection.

Please send us an e-mail to support@bluerobotics.com with your original order number and reference this e-mail and this e-mail thread and we will get one sent over to you. Sorry for the inconvenience!