No audio from mic on the Low-Light HD USB Camera when using QGC rev6?

Is there a way to re-enable audio feature from the ROV (the mic on the Low-Light HD USB Camera) when using QGC v3.2.4 rev6?

We can hear audio from the ROV when using QGC v3.2.4 rev4.

We love to use all of their five senses (acoustic sense!). Especially commercial divers!

Hi Shuhei,

It should work with the last version, can you check if the audio is not muted ?

1 Like

Hi @patrickelectric It seems like there is a issue here with QGC rev.6. This is the same fault as i have. i am back on rev4 until this problem has been fixed.
This led to another issue… There is no programmed buttons in rev.4 for the gripper so i hope we can solve this audio issue in rev.6 soon so we dont have to chose between sound or gripper…

Hi Patrick-san, the audio is not muted. Shuhei

Hi @hub Do you have any idea why we loose the audio from our sub when we install rev.6 ? As far as i know there is several people that thave the same experience now.


Noticed same issue with Rev 6 with loss of audio but not investigated it yet

1 Like

Hi @SHS, we have several PCs (all Win10) but no PC (QGC rev6) can hear. Need more investigation…

1 Like


@SHS, @schoonerlabs, @hub, thank you for the report, an issue was already open and further investigation will be done.


Hi @patrickelectric,

Any update/workaround to fix the issue with audio not working in QGC Rev6 on some computers?

Alternatively, where could I download QGC rev 4 for Windows and Linux? (can only find the latest image on your software setup page).




You can download previous versions of QGC here.
We are going to focus in more stability and improvements for QGC in the next months, you can follow any update related to the audio issue in my previous post, using the github issue link.

super, thanks!

Hi @patrickelectric,

tried QGC rev4 to get the sound, but still no success.

See screenshot below from the output of screen -ls .

i m using different IPs than the default ones for the Raspberry pi and surface computer. Could the default IP be hardcoded somewhere for the audio stream? Any way to correct that?



Yes it’s hard coded.
You may change it at the risk of breaking things.

Hi @jwalser
Has there been any progress due to lost audio in Rev.6?

@SHS You may track the issue here. No audio from mic on the Low-Light HD USB Camera when using QGC rev6? - #8 by patrickelectric

I have been watching that link, but cant see any solotion on the issue yet.

@SHS when there is progress on the issue, it will appear at that link. There is no solution at the moment.

Is there anyone that have the audio feedback from the camera that runs it on Win.10 with QGC version 6? i have tested with several computers now, but still not able to get any audio on the 6. QGC. As it is today i have to chose between being able to operate the gripper with the proper commands with version 6 or use a earlier version where the audio is ok. really like this audio feature.

Hi @SHS,
We are working on this issue.
I’ll get in touch with you with a test build.

Hi @williangalvani
Mutch appreciated, thanks a lot for the effort.
It is always nice to have something to look forward to :blush:
Svein H.