Home        Store        Docs        Blog

Using USB microphones

(Svein H.) #1

I just connected a USB mic to my rasperry pi and lost all sound from my camera. Tried to remove it again to use the mic on the camera, but it seems like the function has been muted. Any suggestion how to recover it or how to be able to use the USB mic?

Software Updates 8 February 2018
(Jacob) #2

Hi @SHS, Can you show a link to the microphone you are using?

Also, go to, open terminal, and enter cat /proc/asound/cards. Show me what it says please.

(Svein H.) #3

Hi @jwalser,
Here is the link to the mic i ordered: https://www.ebay.com/itm/USB-Plug-Mini-Studio-Speech-Microphone-MIC-Recording-Audio-Adapter-For-PC/152896224197?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

I am offshore at the moment, but i am home again tomorrow and wwill test it then.

(Jacob) #4

Ok, this one should work. I’ve tried the same sort.

(Svein H.) #5

IS it just plug and play or do i have to do something else after i have installed it.

(Jacob) #6

It should be plug and play

(Svein H.) #7

This screenshot was taken after i had removed the usb mic. Still no sound in my laptop.
I have rebooted my Vehicle from QGC and disconnected the battery as well without any changes.

(Patrick José Pereira) #8

Hi Svein,

Did you restart the ROV after connecting the USB microphone or camera ?
Check if screen -ls command output in terminal has the NUMBER.audio process.

(Svein H.) #9

This is how it look while i have connected the extern mic into my pi. Still no sound from any of them.

(Patrick José Pereira) #10

Hi Svein,

Yes, cat /proc/asound/cards will check if the hardware is connected and available for the alsa driver. To check the audio stream service, you need to send the output of screen -ls, then we’ll be able to see if the problem is with the audio stream pipeline or in QGC/network.

(Svein H.) #11

Do this tell you what you want to see?

(Patrick José Pereira) #12

Hi Svein,

Thank you for the image, this shows that the audio service (800.audio) is running and able to find your microphone.
If you are running the last companion image (0.0.15) with the last update of QGC (v3.2.4-BlueRobotics-Rev6) the audio should work fine.

Can you check if the volume control of QGC:
and the windows audio mixer are not muted ?

(Svein H.) #13

Yes, i run the rev6 with the latest companion. Also checked that i not have muted the mic.

(Svein H.) #14

The speaker symbol seems to desapare after a while. I need to change from picture/map to get it back on the screen, why is it like that?

(Svein H.) #16

I just downloaded v3.2.4-Rev.6 on another computer and there is still not any audio coming from the Pi.

(Svein H.) #17

Hi @patrickelectric
It seems like there is a issue with the rev.6 of QGC. i downloaded the rev.4 and got my camera audio back again. after that i downloaded rev.6 and rebooted the vehicle and it vent silent again. I was not able to get any sound from my USB mic in the rev.4. i will run on Rev.4 until this is solved in Rev.6

(Patrick José Pereira) #18

Hi svein,

Thank you for the collaboration, we added this issue in our list and further investigation is already in progress, we’ll notify everyone with a fix asap.