NMEA not working in BlueOS 1.2

Hi @EliotBR. I’m trying use NMEA Injector to add a New NMEA Socket but when I CREATE it, nothing happens. I’m sure if I’m doing something wrong or if the version of BlueOS I’m using:
BlueOS Version: heads/ping-fix-attempt-0-gafacf496Bootstrap Version: 1.1.1Build: 1/29/2024, 12:19:51 PMBy Blue Robotics


Hi @gcelec,

We’ve confirmed that this is a consistent issue in the master branch of BlueOS (and I believe in some of the 1.2.0 beta versions as well), and since my ping-fix-attempt image was created from master that explains why that bug is also present there.

Note that the fix I implemented has been merged into BlueOS master, so you should be able to switch back to the bluerobotics dockerhub base instead of using mine (esalexander), but the NMEA issue will still be present until we’ve managed to track it down and resolve it.

1 Like

Hi Eliot,

I’ve set up the NMEA injector using BlueOS 1.2.0-beta8. I can see the data string coming into 220 GPS_INPUT but it’s not being display on the overlay. Is this still an ongoing issue, or is it something that can be fixed?

The GitHub issue is marked as solved, and the relevant commit is apparently present since 1.2.0-beta.6. If creating NMEA sockets is working for you (which it must be if QGC is receiving the messages) then the original issue is fixed.

I unfortunately have very little experience with the positioning aspects of QGC, but I’d assume if the numbers aren’t showing up then either

  1. your latitude and longitude telemetry display variables are configured to the wrong source (e.g. Gps2 instead of Gps),
  2. there’s something else required to show the positions (e.g. configuring a global origin, although I believe that’s only relevant for local positioning), or
  3. QGC’s telemetry widget may filter out messages that don’t come from the vehicle, but that seems unlikely given 220 is the official GPS component ID

I expect @williangalvani or @tony-white may have some more relevant insight.

Hi @gcelec ,

Have you tried setting the Parameter GPS_TYPE to 14 (MAVLink)?

If that solves the issue, we need to add a warning in the NMEA Injector page if that parameter is not set properly.

1 Like

Hi @williangalvani,
Just getting back to this now. The Parameter `GPS_TYPE was set to Auto so I changed it to 14 (MAVLink) and now I am getting Lat and Long on the QGC display.

Thanks for your help