Navigator/BlueOS NMEA GPS not working


I just got my new navigator. I am upgrading from an mRo/PI 3B.
Previously, I sent USBL GPGGA to the vehicle via UDP:::27000,

This does not appear to work.
So I tried creating an injector, with the default values UDP, 27000, 220
I am getting no GPS lock on the UI.

Any thoughts?

Mark Kozikowski

Hi @mark,

I brought this up internally and was told if you’re getting “no GPS lock” then ArduPilot is saying there’s a connected GPS with no lock, so perhaps the issue is with where/how you’re testing the USBL or something?


which you can confirm/set from the Parameters page in QGroundControl.


Thank you for the prompt response.
After it was mentioned to check the parameters for GPS_TYPE, I sent it to MAV. This made no change.
As far as having a gps device connected, hardware includes only the R-PI and Navigator, and I am feeding NMEA GGA messages via UDP:27000, from a simulator.
This setup works with the mRo/Pi setup, but seems to be falling on deaf hardware with the navigator.
Any logging I can check?


The logs for the NMEA injector can be found using the File Browser (in Pirate Mode), at root/var/logs/blueos/services/nmea-injector (here’s a direct link, if you’ve got your system on and connected) :slight_smile:

With the Pikhawk I used the nmea injector to send Cerulean GPS data to the ROV, but since upgrading to the Navigator the ROV doesn’t seem to be using the nmea data

How are you attempting to send the NMEA data? It seems that currently it’s necessary to configure a relevant socket on every boot (that has apparently been made persistent in the 1.1-beta releases)

The instructions I used from cerulean (quoted below) worked with the Pixhawk but when I upgraded to the Navigator they didn’t work.


I’ve moved your NMEA-related messages here, because they’re seemingly on the same topic.

I’m not sure what’s going on here, but I’ve spoken to the software team and they will hopefully be testing the Navigator + BlueOS NMEA Injector functionality next week, to see if they can replicate the issues you and @mark have been running into.

@mark / @CUIS,

Was this the case with BlueOS 1.0.1 stable, or one of the beta images? We added a few different fixes and tests in BlueOS 1.1.0-beta.1 to beta.3. Assuming you were testing with an earlier version, can you confirm whether this issue is still present for you in a recent beta release?

You’ll need to turn on Pirate Mode to access the beta releases, but once you’ve installed one you can easily roll back to stable if you’d prefer to stay on a stable release for your normal operation :slight_smile:

HI Eliot,

I tried this on both the Stable and beta versions I still cant seem it to accept the NMEA Data

I figured it out I changed the GPS-type to MAV thanks

1 Like