GPS issues with BlueBoat?


Is anyone having any problems getting a GPS fix using their BlueBoat or a Navigator in general? We have tried with 2 different BlueBoats and a stand alone Navigator with the same MRO GPS units in the BlueBoats and a Here 2 and we do not get a fix. We have tried using 4 different computers, different versions of QGC, different versions of Mission Planner, and even checked in cockpit in Blue OS and never get an accurate reliable lock. Sometimes we will get a lock but the boat is positioned over a mile away from its actual location, upon reboot it will either not get a GPS lock, or will be in a different location away from its actual physical location. We have lots of experience with Ardupilot UAVs and Rovers, and I have never had GPS issues with I tested all the GPS boards. When these GPS units are connected to a Pixhawk Cube Black, they all get a GPS lock in QGC and MP. I am at wits end trying to get a GPS fix as it is paramount to use these boats for our purpose, and the only thing that they have in problem is using a navigator. Anyone else have any problems with GPS and Navigators? Thanks for your help.


Hi @FairweatherIT -
The most interesting aspect of your issue is that your test hardware, when returned to BR HQ, got GPS lock without issue! I’m eager to hear if anyone else is having similar GPS issues…

Greetings All,

I just wanted to publicly thank Tony and Willian at BlueRobotics for going out of their way to help us get a GPS lock for our boats, that is repeatable and consistent. I will leave the technical details for them to disseminate, but all is working now at FIT HQ. Thanks for your extraordinary help.



1 Like

@FairweatherIT 's issue was VERY unusual.

His GPS worked until plugged into the navigator. Upon inspection, we noticed that ArduRover was configuring it to output UBX (U-blox binary protocol). but upon doing that, for some reason the gps either had no lock or didn’t send the messages required for ArduRover to function.

We worked around it by manually configuring it to output NMEA. this can be done either by using u-center or PyGpsClient. We used PyGpsClient as it is able to talk through bridges. I can write a better guide on how to do this later, but the important thing is you need to get the baudrate right in bridges. that is usually 230400 after ArduRover sets it up, or 57600/38400 from factory, IIRC.

On ArduRover, GPS_TYPE should be set to NMEA, and GPS_AUTO_CONFIG should be set to disabled.
The baudrate on the serial port (SERIALX_BAUD_) must also be set accordingly to the baud you setup your gps to.

Again, this is the first time we see this issue. If anyone else runs into it, please report and let’s us know, as it will need more investigation.

1 Like

We ran into this same issue with Navigator and a uBlox F9P a few months ago. Changed the output to NMEA and it just worked. Any baud rate from 57600 through 230400 worked, but I think we stayed at 230400.

1 Like