No gps fix on standard blueboat

We have no gps fix while using stock BlueBoat. Tried using solution from GPS issues with BlueBoat? but it didnt work. There is a mavros apm node running but apart from that no changes to stock system.

Hi @andersntnu -
Did you have GPS fix at any point during your setup Did you test before setting up Mavros?
You could try (temporarily) removing Serial5 from the Autopilot ports (on Autopilot Firmware page) and then opening the port in the terminal via screen

screen /dev/ttyAMA** 250000

Replacing ** with the appropriate port number, and potentially trying different baud rates like 115200. If you see data coming through the issue may be with configuration elsewhere?

What are the LEDs of the GPS doing? It can be a bit of work to get the GPS out from below the deck, but you can see the color and blink rate without doing so…

I don’t believe we had a GPS lock during setup. We’ve now tried removing the port from autopilot firmware page and using screen with any commonly used baudrate, they all produced gibberish. The LED on the GPS is blinking red at approx. 1 Hz.