Home        Store        Learn        Blog

Motor speed problem upgrading to Heavy

Hi!
I have upgraded a BROV2 to heavy.
When going in manual mode there is much less speed in the new motors.
That means ROV is pitching down when using dive thrust.
In stabilise mode the vehicle is slowly rocking in pitching plane.
Is there a setting to make the new Heavy motors/ESC compatible with old?

The 2 new thrusters and ESC are the latest From BR
The old 6 thrusters are M200R1 and ESC are from march 2017
FYI when running in air, new ESC is applying stop function when input is 0%
Bo

Are you sure they are spinning at all? Did you change the frame to heavy?
Can you share a log so we can check if the pwm outputs are right? This way we can be sure it is an ESC/motor issue.

Check that the PIT parameters you have match the default parameters for the bluerov2-heavy.
specially the _PIT _ ones.

Hi @williangalvani!
Yes, frame is right, motor page is right (8 motors and correct frame ).
Same problem when spinning motors from settings page.
The 2 new is spinning much slower on the same amount of slider.
But when pulling the slider to the ends there is full speed.
Also the Motors/ESC has a breaking function that the old has not.
IE when going from speeed to stop there is a quick braking function.
PIT parameters seems right. They should not make differens in manual and setting mode?

What kind of log do You want and where do i find it?

Actually, just check if the values sent to the 4 vertical motors are the same (same absolute offset from 1500 when applying throttle up/down).

It does sound like a ESC firmware issue, but this way we can be sure.

Good instructions, here are Servo_Output_RAW:

Hi @williangalvani
Any ideas how to make the upgrade kit work?
Bo

@Boko Are the ESC hardware models the same? Can you take a picture?

Hi @jwalser
Long time!

No, the ESC are really not the same.
New is latest delivered last week
Old is spring 2017, larger, maybee before BR made own
From invoice: SKU: ADVPKG-ARDUSUB-PIXHAWK-R1
Not easy to take pictures as now
One clew: “Also the new ESC has a breaking function that the old has not.”
/ Bo

While this is not the best or most practical solution, you could try configuring the new ESC to disable breaking. It should be doable with an Arduino relatively fast.

Apparently it is not possible to disable it in the current firmware.