Home        Store        Docs        Blog

MAVLink REST API not working after 0.0.20 update

Hi Jacob,

Hi did the update but the process froze to a certain point, I let it quite a long time. I then refreshed the system page and the companion appeared to be updated to 0.0.20.

I tried the ROV and it seems to be working fine but is there a way to be sure the installation process has been completed? I tried to reach to …4777/mavlink/ATTITUDE/pitch for a trial but it tells me the link is not valid.

Now I do not have the update button anymore of course. Can I do a companion software full installation control or upload a zipped update instead? I will flash the card otherwise but If I can avoid to open the ROV will be better.

Steven

Hi @Stevenlb,

Check first if 192.168.2.2:4777 has a valid webpage, if not, something is wrong with your installation and you’ll probably need to flash a new image.
But if the path is valid, check our notes for the REST API related problems here, it’s necessary only an update of you vehicle parameters or a modification in mavproxy configuration if it was modified previously.

Hi Patrick,

It says "mavlink2rest - 0.2.1 - 2020-01-10
By: Patrick José Pereira
Check the mavlink path for the data
You can also… "

and on mavlink path I have: {}

Is that ok?

Hi @Stevenlb,

As I said, you need to follow the instructions in the link from my previous post related to the vehicle params and if necessary mavproxy configuration.

I did the “Restaure default options” on MavProxy and now I get all the data in …4777/mavlink so my companion update worked. I guess that was because I updated from 0.0.18 to 0.0.20.
Thank you for your help @patrickelectric.

This topic was automatically closed after 3 days. New replies are no longer allowed.