MacOS Monterey 12.2 - UDP not working


I am using a Raspberry Pi 3 and pixhawk. The raspberry pi has ArduSub software installed and it is connected to my computer through an ethernet cable. I can see the Pixhawk in the ArduSub software and it is listed as Pixhawk1. However qground control is stuck on waiting for a vehicle connection. I have tried restoring and flashing the Pixhawk. I have rebooted my computer. I have changed the usb cables in between raspberry pi and Pixhawk. I have changed the ethernet cables. Nothing seems to work. In the console you can see Mavproxy working fine as well. From the troubleshooting steps I have done them all yet it doesn’t seem to satisfy this problem. What is the issue here?

Hi @ufocet,

Assuming this was in the Companion web interface, that means the Companion computer is connected to and communicating with your computer, so the issue must be with specific programs or connection types.

Have you allowed QGroundControl through your firewall? If you’ve already done that, please also confirm you’ve followed our firewall troubleshooting recommendations :slight_smile:


Yes the companion computer is connected and communicating with the computer. I am using a MacBook and the firewall is currently off. I think all incoming communications are allowed. Are there any other troubleshooting steps you recommend?

Also to reiterate, when I plug in the Pixhawk via usb cable directly onto the computer the qground control detects the Pixhawk. The problem is when I connect it via the companion computer, the companion web interface sees the Pixhawk on the serial connections. However the qground control software is stuck in the “waiting for vehicle connections”

  1. What versions of things are you using?
    • MacOS _
    • ArduSub _
    • Companion _
    • QGroundControl _
  2. Is the video stream working in QGC, or is there no connection to it at all?
  3. Are there multiple possible devices to set the network configuration on? And if so have you set it on the right one?

Here are the versions I am using:

MacOS Monterey Version 12.2
ArduSub 4.0.3
Companion v0.0.31
QGroundControl v4.0.5

There is no video stream working in QGC, no connection at all.

I am using a dongle to connect the ethernet cable so I am using the USB 10/100/1000 LAN port and I have double checked the IP address configurations are correct. I never use a LAN cable other than this. Thus I do not think there would be multiple possible devices set to this network configuration.

I hope this helps.

I’m on the same ArduSub, Companion, and QGC, and am currently on Monterey 12.1, although I don’t expect there to be significant differences between 12.1 and 12.2.

Are you on Intel or M1? I’m not sure if we’ve tested much (if at all) with M1 yet - that’s the biggest potential difference I can think of.

I’m also a bit confused - you seem to have managed to get a connection working a month ago, did that not include an autopilot connection or video stream, or have you since changed devices or something?

I am on Intel.

I am also confused. A month ago I had autopilot connection, video stream. I could control the motors from qgroundcontrol… Everything was working fine. I had finals and it was holiday season so I took a break. I just got back plugged everything in and this problem occurred.

Since than no cable, no device has changed. Everything to the cable was the exact same. Only thing that could have changed may be the version of the Mac I am using.

It is really frustrating knowing they worked perfectly just a month ago. I have no idea what is wrong and I don’t want to replace a perfectly functional Pixhawk at this point in time. Can Pixhawk’s loose their function over time, is that even a thing?? But even if it is the thing works when plug it directly to my computer?

That’s really weird…

Hmm, possibly a bug in Monterey 12.2 then, or some kind of settings change?

Just did a search for “macos monterey 12.2 udp broken”, and one of the results was this osxdaily article about the 12.2.1 update, where someone has commented

so it’s at least conceivable that that’s the cause of the issue. That said, it’s still a somewhat tenuous link, particularly given someone responded to them saying “Everything works fine for me”.

There’s also this Apple support thread, where 12.2 apparently fixed some UDP issues, although that may also mean they’ve fixed one issue with UDP and in doing so may have broken something else…

If that actually is the issue though, your options are either waiting for the next update and hoping it fixes it, or downgrading (which is a pain, because it also deletes all your files). It may help/speed things up to contact Apple support and/or post on their forum.

If the Pixhawk works via serial then it’s not a Pixhawk issue (the Companion computer talks to the Pixhawk over serial anyway, it’s the connection from the Companion to the topside computer that seems to be the problem, and specifically UDP communication).

Hello again,

Thank you so much for your fast replies. I have used my old Mac computer and everything worked just fine. It seems, as you guessed, apple broke something on their last Monterey 12.2 update. I think I will use this old laptop until apple deals with this issue.

Thank you so much again.

1 Like

I’ve just updated to MacOS 12.3 (I skipped 12.2), and QGroundControl had no issues connecting to the telemetry and video stream. Might be worth a shot, and if it doesn’t work then there’s likely some other issue with your settings/computer :slight_smile:

I am on mid 2012 MacBook with Catalina 10.15.7 and have the same issue. Can you follow with what you are on that IS working please?