Help with Qground crashing

Can any one help with a solution. Running a 2012 Mac Book Pro 2.9 GHz Intel Core i7 with 16GB Ram. and QGround keeps crashing frequently. I have tried uninstalling it and re installing it, everything is up to date. i will post screen shots below.


Hi @Atmoinspections, sorry you are having trouble. Does the crash occur randomly, or is it repeatable (like it always happens after you click a certain something or plug something in)?

Please try rebooting your computer.

Hey Jacob. I have tried restarting the system. I have removed and reinstalled the program. Seems to happen about every 7-10 mins. Also happens while the USB is plugged into the laptop. And also when plugged into the wall. And has been happening during recording And we lose all recorded material. And also will happen when it’s not recording.

Not too sure what else we can do.

I get the the same, routine crashes, MacBook Pro 2010, 10.12.6.

I’m updating to 10.13 to see what difference that makes. Will report back once updated.

At least a restart of QC takes fifteen twenty seconds before control is regained.

great thanks, hope we can get a fix.

I am already using 10.13.5

it isn’t the crashing and having to restart the app that’s annoying, loosing the recording footage is worse.

The intended/expected behavior is for the video file to be preserved in the event of a crash or running out of battery etc. So this is some bug on top of the crash. I’m sorry to hear about this.

@Atmoinspections, @Dale_A I will PM you guys to sort things out, and we can follow up here with the resolution when we get there.

Thanks Jacob.

I run qground control through a 2012 MacBook Pro and have experienced the exact same thing - quitting unexpectedly and loosing the video file (the file is there but it is corrupt and won’t play, and cannot be repaired).

Has happened on a job (very annoying), and also testing on the bench.

Haven’t experienced it with running through Windows, but really don’t want to revert to that as the video quality is a lot worse, as well as the entire experience with windows :wink:

Any assistance with a fix would be appreciated as it makes using the Blue2 unreliable commercially.



Indeed. Having crashes while inspecting fenders and piles on a jetty is no place to discover your ROV has taken up tether macrame while you recover QGround.

Submit your crash logs, and fingers crossed we will be back working OSX reliability

Three observations regarding this theme:
1 For some time now I had MacOS 10.13.5 (MacBook Pro Retina 2015) giving me the same error message Russ reported, but only after I quit QGC with the gamepad (Logitech F180) still connected. If I first remove the gamepad before quitting, I do not get the error message. Also, the gamepad sometimes behaves strangely, switching controls from the “cross” on the left to the left joystick. Is there someone out there with a mac and a different gamepad that does or does not give trouble?

2 I only once had a crash during a dive, resulting in a damaged mp4 file. However, I was able to get the video repaired.

3 I just updated to 10.13.6, but I still get the error message when quitting QGC

Hope this helps with troubleshooting,

What version of MacOs are you using? The common theme so far appears to be users on 10.13.x. I’ll add @rovinnovations and @KaiH to the PM group for troubleshooting.

So far I have not been able to determine the exact problem. So far it appears to be a bug in Apple’s HID (human input device) driver. For anyone that experiences this issue, please DO click send error report to apple.

Hi Jacob,

I think, the problem started after the update from 10.13.4 to .5, but I am not sure. It persists with 10.13.6, which I updated to today. Next time I will send the error report to apple.

Cheers from Germany,


Thank you to everyone trying to help figure this out.

Has anyone tried running like 1/4 of their Mac with windows?

Yes, but not QGround. That was with Parallels, not bootcamp. That machine cooked itself, so I’m not able to test run QG.