Help my to build a Autonomus Catamaran

Hello everyone, I hope you’re all doing well. I just wanted to start by saying how awesome this forum is! Now, as part of my studies, I need to develop a small autonomous catamaran. The main goal is to provide it with points on a map that it will then need to follow. Additionally, it’s equipped with a camera and various sensors to gather information about the seabed. The catamaran is divided into two parts: the acquisition part and the control part. We’re focusing on the control part.

I’m happy to share that I’ve successfully connected and calibrated the GPS, accelerometer, and compass. Now, onto the next challenge…

I should mention that I’m quite new to the world of drones and autonomous vehicles. Despite being a beginner, I’m eager to learn and tackle the tasks ahead.

The person who previously worked on this project installed two ESCs and brushless motors from Blue Robotics, along with two servo motors to adjust the direction of the brushless motors. Everything is connected to a Raspberry Pi 4 with the Navigator shield.

On the Navigator, we have connected a GPS Classic M8N - IST8308, which serves as both a GPS and a compass. In the future, we’ll be using the router and base station for communication.

I’m facing several configuration issues. Initially, I thought of using the BlueBoat configuration, but I’ve been unable to achieve anything with those parameters. If any of you have advice or explanations to help me move forward, I would appreciate it.

Thank you very much in advance ! :smiley:

Hi @Laughing_Josh -
The BlueBoat steers with differential, “skid” steering, using only two motors to control the vehicle heading. It seems like your boat does this, but also has the ability to turn the motors! This is not a standard frame in ArduRover, so you may have issues. I would recommend setting the thrusters to point straight, disabling your steering servos, and connecting the ESCs to channels 1 & 3 to match the BlueBoat configuration.
The only other thing to watch out for is the autopilot orientation - by default in the BlueBoat it is mounted upside-down, so this may need to be adjusted to match your vehicles configuration.
Best of luck!

To follow up @Laughing_Josh -
It seems Rover does have support for vectored thrust as you have on your vehicle. Give it a try and let us know how it goes!

Following your information, I connected the 2 motors to pins 1 and 3. Initially, my BlueOS was configured as BlueRov2, and I could test the motors from the BlueOS interface. However, once the configuration was changed to BlueBoat, it’s impossible to arm the motors or move them. Even if I change the motor configuration from throttle to motor, I still can’t get them to work. I also tried from QGroundControl and Mission Planner, but it’s not allowed. Do you have any idea why or how to solve this?

The arduboat firmware which is what the BlueBoat configuration is based on is a little bit more stringent about failsafes.

Using Mission Planner and the BlueBoat configuration, try arming the vehicle. If there is a failsafe condition preventing you from arming, it should be indicated in a pop up notice and/or the messages tab. Make sure all of the failsafe conditions are satisfied and you should be able to arm the vehicle with the BlueBoat configuration. Once you have done that you should be able to arm the vehicle and test from the interface.

1 Like

Hi @Laughing_Josh -
I agree with @TMJ - when you changed firmware from ArduSub to ArduRover, it cleared your parameters, including any accelerometer and compass calibration you may have done. You should see a message in QGroundControl if you try to arm the vehicle. If you calibrate the motion sensors, and have GPS lock, you should be able to arm and test the motors. You can also edit the failsafe parameter FS_GCS_ENABLE to check for nothing, and then be able to arm and test the motors as well.
The BlueOS control of motors for testing with ArduRover may have an issue currently - I would recommend using the QGround Control motor test page.

1 Like