GPS signals to QGC

I suppose these packages are not installed now? And if I guess right, some computer “magic” is necessary to set it up and get it working? Sometimes I wish I was a computer geek so that I actually could understand all this properly :slight_smile:

The only thing that you need to do is put your NMEA data on UDP port 192.168.2.2:27000.

This software can do that for you.

My setup is a little complicated (my rov connects to an Ubuntu desktop running a Win7 VM for the USBL), so I’m sending my data from a file to the UDP port. However, I do use the NMEA Router software that Jacob just linked on my Windows VM, and it should be fairly easy to set up the serial–>UDP that way!

Still not able to get the position onto the rov panel. The NMEA signal comes in on COM10 and is sending out to Remote host 192.168.2.2 - Port 27000

Tried to swith GPS settings in QGC to NMEA, also no luck, now put back in Automode also

image

Ok @SDI,

The program taking the data in on the ROV only accepts GGA. I will update it to accept some more message types and let you know when it’s ready.

-Jacob

BR2 transponder GPS position on the display. Finally :slight_smile:

1 Like

Are you running the waterlinked system or GPS for surface positioning only?

I am using a different system (Blueprint Subsea USBL) The position seen on the display is the ROV position, Not the surface vessel or GPS.

Was there a resolution to the issue of connecting a gps to the laptop and displaying the lat & long on the widgets?

You may connect a gps to the laptop, and the position will be displayed on the map. The lat/long coordinates are not displayed.

Thanks Jacob, any plans to make this possible in the future?

Not that I’m aware of, you can search/add a feature request in QGC: https://github.com/mavlink/qgroundcontrol/issues

Many thanks, Jacob.

Hi Oystein,

I am trying to get my GPS data displayed on QGC and am wondering what you finally did to get the LAT/LONG to show on the display. I have tried sending it to UDP 27000, but no luck. Would very much appreciate it if you could tell me how you did it.

Thanks,

David

Are you using a USBL, WaterLinked or just surface GPS?

I followed a procedure that Jacob explained to me. I believe I made a “how too” procedure with text and figures. I used a free software called nmea router. I Will look for the procedure

Hi All,

Thank you for responding. I used NMEA Router too. Rusty at Blue Robotics told me I should just try disabling GPS in the QGroundControl setup because is was somehow conflicting with NMEA Router. I did it and it worked. I just sent it to UDP 27000. That’s it.

Best regards,

David

I know its an old post , but how do you disable GPS in the QGC

Hi @Mac1

Maybee to many places, but better safe then sorry (numbers 1-3 refering to picture):

  1. Turn of RTK GPS
  2. Turn of connected NMEA
  3. Turn of connections in Commlinks
  4. Do not send NMEA to QGC other then thru Companion 192.168.2.2:27000
2 Likes