Home        Store        Learn        Blog

GPS signals to QGC

Not that I’m aware of, you can search/add a feature request in QGC: https://github.com/mavlink/qgroundcontrol/issues

Many thanks, Jacob.

Hi Oystein,

I am trying to get my GPS data displayed on QGC and am wondering what you finally did to get the LAT/LONG to show on the display. I have tried sending it to UDP 27000, but no luck. Would very much appreciate it if you could tell me how you did it.

Thanks,

David

Are you using a USBL, WaterLinked or just surface GPS?

I followed a procedure that Jacob explained to me. I believe I made a “how too” procedure with text and figures. I used a free software called nmea router. I Will look for the procedure

Hi All,

Thank you for responding. I used NMEA Router too. Rusty at Blue Robotics told me I should just try disabling GPS in the QGroundControl setup because is was somehow conflicting with NMEA Router. I did it and it worked. I just sent it to UDP 27000. That’s it.

Best regards,

David

I know its an old post , but how do you disable GPS in the QGC

Hi @Mac1

Maybee to many places, but better safe then sorry (numbers 1-3 refering to picture):

  1. Turn of RTK GPS
  2. Turn of connected NMEA
  3. Turn of connections in Commlinks
  4. Do not send NMEA to QGC other then thru Companion 192.168.2.2:27000
2 Likes