Home        Store        Learn        Blog

MicroNav USBL GPS on a BR2

Hello
I have a MicroNav USBL GPS positioning system working with Genesis program , I am trying to connect the ROV transponder (T1) GPS reading to BR2 QGround control , i have tried connecting through an NMEA router but it is only the main surface transducer GPS position that it transferred into the QGroundcontrol program .

Does anybody know how i can change this GPS main position input and only have the actual ROV transponder GPS position input onto the QGroundcontrol program

simple easy instructions if possible please as i am not a computer whiz kid :slight_smile:

1 Like

What are the udp addresses you are routing? Are you routing a serial port to a UDP port?

I am routeing through remote host 192.168.2.2 and remote post 27000 ( as the Qgroundcontrol listens on )
i am able to route the main surface transducer GPS reading into the BR2 program but I am not able to change it to the GPS actual position of the ping transponder
so all get at the moment on the BR2 display is the GPS reading of the surface transducer and not of the actual position of the ROV underwater ping transponder

Hi!
I think you should check what is possible in the USBL program output settings (Genesis?)
There you might be able to setup to send ROV position only, and not topside position.
You only need to send GGA sentences

1 Like

I have spoken with Genesis (Tritech) technical support team and they were only able to tell me to set the output I/O so that it was supposed to go back to the Navhub and come out hub port A and with $GPGGA format, but when i connect a second laptop to the Navhub A port with a USB cable no GPS signal/stream is evident .

only options on the output I/O are Navhub ports A,B,C or coms ports, i attempted to put the output out through a different USB on laptop one and connect a USB to USB between the two laptops , but still no signal evident

all my firewall settings have been disabled to off so as nothing could be blocked by the firewall

I’m not familiar with the Gemini USBL, but when I’ve used other systems I’ve send the surface position to UDP port 27000 to see if QGC is receiving it, then when I’m able to wet test it, I change the software to export the vehicle’s position.
I think the answer to your problem is within the Genesis software as QGC seems to performing correctly with the information being sent to it.

Hi thanks for the information, where do you change the software to export the vehicles position in the QGC program ? what steps/instructions ?
thanks

QGC can not change from where the postion is coming.
You have to set that in the system/software sending position NMEA.
Apart from Genesis, Tritech has the software “Seanet Pro” where you can do a lot.
Check from page 105 in this manual:

1 Like

Hello thanks for your assistance , do you have a tritech micronav and blue robotic system GPS running like correctly on seanet (or have done in the past)? if yes this is great to hear that the two are compatible as i have being speaking to blue robotics and tritech technicians for the last week and still not been able to out put the pinger GPS into QGC , it always goes through as the base GPS position, but that has been with Genesis program not seanet program
any help in resolving this issue would be greatly appreciated thanks

Hi!
Long time since Micronav for me, using Waterlinked with BR.
Micronav should work with BR
Your communication with QGC works so there is nothing to do.

Is it possible to get the NMEA direct from USBL topside port?
Trick for You is digging into checking NMEA strings from USBL system
It seems Seanet can sniff and show NMEA strings

Also lot of other programs do that, even freeware like Open CPN navigation plotting program.
OpenCPN has possibilities to filter and change NMEA messages
But all that depends on that you have the USBL system to send transponder NMEA position, not topside GPS position.

1 Like

Hello Bo , i have finally managed to route my Genesis pinger from one laptop to another so that it is the only GPS reading that is coming into the second laptop , I have tried to to route it through the NMEA router as i had done before for the main GPS reading , but now when i route the pinger GPS thread through the MNEA router the GPS reading does not show up on the QGC ! any ideas on another way i could route the pinger GPS data , i have included a few pics of my set up including the docklight input thread , thanks for your help




In QGC Settings, under ‘AutoConnect to the following devices’ section, uncheck everything but ‘UDP’.

Give that a go.

Hi just tried that but no luck still no GPS reading also tried to connect to the coms port option instead of UDP , but that did not work either :frowning:

where/how did you change the software to export the vehicles position ?

thanks

I was using a Subsonus USBL system. The software is URL based so you connect to the Subsonus directly through a web browser. I made this video for the client that I set it up for. https://photos.app.goo.gl/zKSWZkmkRBHdVYM58

The NEMARouter screen looks correct. Is that running on the same computer as QGC or do you have a LAN switch between your QGC computer and your NAV computer? Just curious.

What do you see when you run screen -r nmearx command on Raspberry pi’s terminal?

Are you running the latest companion release?

I run CeruleanSonar’s USBL. It forwards location to 192.168.2.2:27000.

hello , i run the Micro nav on one laptop and forward its USBL pinger GPS reading to my other laptop and it comes in om COMs port 12 , i then pick it up on the input on the NMEA router and put output on the NMEA UDP at 192.168.2.2:2700 and have the QGC set to listen on that stream , but for some reason the QGC is not showing the pinger GPS reading .
where do i check to see what is running on my screen -r nmearx command on Raspberry pi’s terminal ?
thanks

Happy New Year,

192.168.2.2:27000 is the port that the companion RPi computer listens for NMEA data. It then forwards it to QGC.
Open a terminal on the companion at : http://192.168.2.2:8088 Then enter the screen command. That will tell you whether the NMEA is making it to the companion.

Happy new year to you also ,
sorry but where do i open a terminal ? and when you speak about a companion do you mean my laptop ?
sorry not into computers :-/

NP,
Make sure the ROV is powered on, and connected. On the laptop that runs QGC, open a web browser, and go to 192.168.2.2:8088. That’s the terminal access website on the RaspberryPi.

The manual is here: https://www.ardusub.com/ Check out the section on the Companion Web Interface