Home        Store        Learn        Blog

Help in integrating WaterLinked GPS system in QGroundControl

Hi all,

we are having a problem with our atempt to simplify solution for BlueRov2 and WaterLinked underwater GPS implementation trough QGroundControl.

So, we tried connecting BR2 and WL UGPS trough a switch, and that combination, more or less, works as expected.

Our surface computer is a Lenovo laptop, without direct LAN ports, so we use USB to LAN adapter (https://support.lenovo.com/hr/en/solutions/pd029741) to comunnicate with ROV or with ROV/UGPS combination trough switch.

We bought a second USB to LAN adapter, wanting to connect BR2 to first usb adapter, and UGPS to second usb adapter, giving them fixed, different IP adress. When we hook everything up, we can get ROV communication in QGC, and Waterlinked GPS position in browser (static IP 192.168.2.94).

Unfortunatelly, we cannot get them to connect trough QGC, so there is no GPS position in QGC.

What did we do wrong?

Fixed IP adresses for USB to LAN adapters are:

BR2: 192.168.2.2
WL UGPS: 192.168.2.3

I have 3 available usb slots in laptop, and I tried to connect them in every possible combination, but still couldnt get them to communicate trough QGC (thinking maybe usb controller may be the cause of this issue).

BR2 is up to date (companion v0.0.20, ardusub v4), also, QGC is up to date and so is the UGPS from Waterlinked.
We even tried same setup on older builds (both ROV firmware and QGC version), without any luck.

What are we doing wrong, and is there a solution like this that is possible to configure?

We would really apreciate if we could de-clutter the setup as much as possible…

especially when working on boat…

This can be done several ways
1)
The BR way
Buy Waterlinked integration kit
That use an extra fathom X card giving a total of 3
Then by hardwire splitting, all 3 cards are connected by/to teher

By traditional ethernet, ie 1 a switch or router
Here you connect everything like traditional network.
One port for computer, one for ROV topside fathom and one to Waterlinked network.
We have built this solution inside the waterlinked box.
You could also have the ROV fathom card here

IP adresses has to be right.
As default Waterlinkeds built in dip switch give 192.168.2.94
Then if using standard settings, Companion will automatic find Waterlinked and start.

One thing that might be wrong with your setup is that by using two USB adapters i think the ROV/companion is not bridged in the two USB adapters, and by that not seeing the Waterlinked.
/Bo

1 Like

This! We recommend using this IP address for the Waterlinked GPS.

Precisely! If using Windows, you can actually bridge both usb network adapters together and set this new bridged network to 192.168.2.1

Normally you will have two different ip adresses if you connect two ethernet adapter to one pc, this might give you some trouble.

We connect external GPS with heading, Waterlinked and Bluerov2 to a hub in the Waterlinked pelicase. Works very well.