Home        Store        Learn        Blog

MicroNav USBL GPS on a BR2

HI , getting an error message in the PI
any thoughts on how to resolve the issue ?
thanks

image

Well it looks like the data is getting to the Pi. Kinda good news.

What companion version are you running? 192.168.2.2:2770 System tab.

windows 10
do you mean what IP the ROV connects to the computer ? if yes its as advised on set up

IP 192.168.2.1
sub 255 255 255

Hi @Mac1
I usually use GGA instead of RMC strings, otherwise looks good.
And again: is it transponder position and not GPS position you get from Genesis?
Another thought: is transponder and USBL head in water so you have acoustic communication?
If not, some systems send GPS position instead of locator position

FYI when sending NMEA to 192.168.2.2:27000
It actually goes to companion in the ROV tube, picked up there and then via scripts in Companion up to QGC.
That means all involved equipment must be on same network, powered on, and communicating (test via ping)
In QGC you should turn of all other GPS inputs, as the postion comes from Companion computer.

Hello Boko
thanks again for your updates, yes on laptop 1 i have the genesis program running , transponder and transducer in water and pinging back and for so all operating, then i send the transponder position t from the I/O output on micronav hub and just the ROV/transponder position comes into the second laptop, if i disconnect the power to the ROV transponder then i loose the signal coming in on the NMEA router on my second computer , so it is only the transponder GPS position coming in on my NMEA input into laptop 2.
then i have routed the NMEA for input from coms 12 and output to UDP 192.168.2.2:27000 and i can see the transponder GPS position streaming as supposed to be
with all systems powered up I have tried going into parameters on the QGC and opened GPS and played about with different settings in the hope that i could turn off the GPS inputs , but nothing that i did seemed to resolve my issue and i am still not getting the GPS position to show on QGC control panel
where and how exactly do i disconnect the GPS inputs ?
thanks appreciate your help

Hi @Mac1
Regarding disconnecting QGC GPS:

The “UDP” box in picture above should be checked so you have NMEA from Companion.

When Companion in the ROV starts receiving NMEA and resends to QGC, you should have an audio message like “EK2 changed” and also a change in the QGC log (click the loudspeaker symbol in top list QGC)
Double check so ALL of your IP units could communicate, use Ping command to check them.
(ROV/Companion, QGC computer, Laptop 2)

HI Boko ,
I am beat , tried all but still no transponder position on QGC screen, something somewhere else must be blocking it as all communications seem correct , when you speak about the IP units which exactly do you mean ?
you must have good patience been able to dealing with me :slight_smile: thanks



Hi @Mac1
Many hats to have on our heads for ROV fixing… IT, Electric, safety, mecanical, marine…

To check network communication betwen all units:
Use command ping to check that, for windows:

Using that on one unit, could be laptop 2, use the command to test reaching the others.
You have to find out IP adresses for those units.
ROV/Companion, usually 192.168.2.2
QGC computer usually 192.168.2.1
Laptop 2 should be like 192.168.2.??
So commands is like: ping 192.168.2.2 (followed by enter)
Then you should have response like in the linked example above
Try this between all units
If you do not get answer betwen any unit you have found a problem

they all seem correct to me
image

hi @Mac1
Is QGC laptop same computer as Laptop 2 with NMEA routing?
Earlier in this thread you had GPS positions going into QGC, what is different?

Hello Boko
yes before i had the surface GPS thread coming through the NMEA router and readout on the QGC panel , but looking back I think this was just the actual GPS feed from my Ariel which was coming through the Microhub and going through the NMEA as a GPS position with 6 or more satellites feeding it , now it is just the Transponders lat and long information coming through the NMEA router the QGC does not want to accept it , i also tried cancelling the number of satellites requires in the QGC GPS control and changed it from 6 to 0 , but that still did not allow the transponder lat and long position to be visible on the QGC control panel.

Laptop one has only the Tritech Micronav Genesis program running on it and as instructed by tritech technician i re routed the transponder position through the I/O output data in GPGGA ( also tried all the other data streaming options )

on my second laptop i have the transponder position information coming into that laptop (Coms 12) then route it through the NMEA router input serial coms port 12 and output UDP 192.168.2.2:27000 , where i can see the transponders position data displaying on the NMEA

on the second i open QGC and connect BR2 and arm the vehicle ,then i tried all combinations to get the transponder position to show on the QGC control panel

1)switched off GPS as advised ( NMEA router on/off )
2)tried NMEA UDP 27000 on QGC
3)tried connect direct to serial port coms 12 and then stopped NMEA router

for all of the above i tried changing the data stream from GPGGA to GPRMC and all the other options available on the genesis output option on laptop one

it must just be some option that i have not clicked on , tried all combinations , but cannot seem to get the correct one :frowning:

Hi @Mac1

What version of software is loaded in the Raspberry Pi?
And is the SERIAL0_PROTOCOL set to Mavlink2 ?

Hi
I have tried to find that information , do you mean the QGC program ? if so its the latest version V4.0.5 and sorry i am not sure where i find/check where SERIAL0_PROTOCOL set to Mavlink2 is correct , its my first time i am having this sort of problem and never had to check all these things so i do not know my way around the program, raspberry PI or any of the operating system
thanks for any guidance

This solution form Blue Robotics is a great platform, and us BR users are a great community that supports each other.

With the ROV on, and connected, open a browser in the QGC laptop. Go to 192.168.2.2:2770. Click on the System tab. Scroll down to the ArduSub Companion Computer Setup section. That will tell you the version installed in the Raspberry Pi. It may tell you there is a newer version available to install.

Then is QGC, open the Settings. In the Parameters section, look for the search bar, and enter SERIAL0_PROTOCOL.

Hopefully these steps will get us closer.

Hello
yes this BR platform is great and very helpful people on it , like yourself and Boko who is willing to spend time and assist people like me

software is 0.0.17
Serialo_protocol is Mavlink1

thanks

You will need to update the software to the latest. There is a “Stable” button in the ArduSub Companion Computer Setup section. Make sure the ROV has a good Wifi connection. You can make sure it is connected by clicking on the Network tab at 192.168.2.2:2770.

Also, change the SERIAL0_PROTOCOL to MavLink 2

I think we’re getting closer…

@Mac1,
I want to mention, the Companion update takes a bit of time, Be patient. Watch the window for progress

installed/updated as requested
still no transponder reading on control panel
should i re boot pixhawk ?
should i be going through the NMEA Router ?
what settings on the QGC should the auto connect to the following devices be set to ?


You will still need to run the NMEA router on your QGC laptop, forwarding to 192.168.2.2:27000

Now that you’ve updated the Raspberry Pi, please go back to the Terminal window, 192.168.2.2:8088. Run the screen command and see if it’s happy.

Oh,

You’d be best to power cycle the ROV now that you’ve done all that.