'EKF3 lane switch 1' warning when armed


I have received the following warning several times recently:
EKF3 lane switch 1

It happens when the BlueRov2 is armed, but I did not notice any dependence on e.g. flight mode (manual, depth hold or stabilize). ROV sensors are calibrated.

The warning has no noticeable effect on the work of the ROV or the responsiveness of the QGC. Both the bandwith (in Test network) and the Loss rate (in QGC MavLink link status) values are fine.

I am using QGC version 4.2.3 and the latest Companion (0.0.31). I tried switching to BlueOS but failed to set serial data routing from Raspberry USB to UDP port (which is necessary for my work).

I have not found a description of a similar problem on the forum.

Where can I start looking for a problem solution?

Hi @en_morty,

As I understand it that’s a notification more than a warning - ArduPilot’s EKF3 Lane Switching documentation says the EKF runs an instance per IMU, and if one set of sensors is misbehaving (or just noisier) it switches to another.

It may be worth doing a sensor calibration - if the notification persists there may be something wrong with one of the sensors on your autopilot board.

That should be possible using the Bridges page (requires Pirate Mode). We recently made some significant quality of life improvements to that page, so if you try out 1.1.0-beta.6 it should be extra pleasant to use :slight_smile:

Of course any feedback is welcome, and please let us know if something isn’t working as expected :slight_smile:

Thanks for response.

Ok, I will do it next time in the field.

6 posts were merged into an existing topic: BlueOS Bridges not working like Companion

@EliotBR Hello, I am having the same error. EKF3 Lane switch 1.
Do you have a suggestion for a solution? EKF3 Lane switch is between 1 -0.
I also get EKF2 IMU1 Forced reset error. Can you help me?

Hi @Busrakck, welcome to the forum :slight_smile:

I’ve merged your duplicate post into this thread to avoid spam.

As above

If that’s something you’ve already tried, can you confirm

  1. that the calibration was successful and high quality
  2. whether this issue is occurring consistently, and if so
  3. whether it happens when the vehicle is moving, or only when it’s still?

We were getting this problem when Ekf3 was enabled. We were getting Ekf3 imu1/0 forced reset and Ekf3 line switch 1 or 0 warning. In this case, EFK3 is disabled, we have enabled Ekf2, this problem has been solved, but this time we started to get continuous depth sensor error and again we rarely get Ekf2 imu1/0 forced reset or Ekf2 line switch 1 or 0 warning.

Just a quick addition that we too are getting “EKF3 lane switch 0” and “EKF3 lane switch 1” when the vehicle is moving.

Note that the vehicle sensors had been calibrated, though we went ahead and did them again. We (twice) received a “yellow” for the compass calibration.

1 Like