EKF IMU Forced reset

Hi I’m hoping someone here can help me diagnose a problem I’m having with the new BlueROV2 I just built.

QgroundControl: 4.2.6
Companion version: 0.0.31
ArduSub version 4.1.0

  • Bar30
  • Celsius Fast-Response Temp Sensor.

I’m getting constant EKF3 IMU0 / 1 forced reset and all kinds of warnings. I have calibrated all the sensors, rebooted the ROV and software. But the warning is still there.

See attached pictures.
Can someone help me diagnose this problem. Do I have faulty sensors / Pixhawk? Could this be a software problem? Can I change some settings or something?

I have a Bluerov 2 running BlueOS (Same Ardusub/QGC) with the exact same issues. I’m expecting it to be a Pixhawk fault, due to having a lot of issues with flashing ardusub onto it, but I’m not able to do a swap till later today/Friday (Grabbing a working one of another unit). When I get to it I can let you know how it goes if you haven’t already tried a Pixhawk swap.

1 Like

Yes please… No I have not tried change the Pixhawk… Don´t have a spare… I was hoping that it would not be faulty Pixhawk… Please let me know how it will handle this problem.

So from testing i have some bad news.

I swapped the pixhawk out for one i currently had in a working machine and that after a calibration the IMU 0/1 resetting completely went away and i was able to keep in running with out issues for a while in my test tank.

Just to check afterwards, I swapped the pixhawk i had taken out into the other machine and the other machine instantly started receiving the IMU forced reset errors.

I’m not sure what is failing on the Pixhawk however, that seems a bit hard to diagnose (Can’t see any visible damage to the board), so if its fixable i have no idea.

1 Like

Thank you for testing this. I will need to do more testing my self, maybe I will need another Pixhawk!!

This seems like a great opportunity to upgrade to the Navigator flight controller

1 Like

I was thinking of that… But as my Sub is newly built, and I’m just starting to use it. I cannot justify as of yet to do that upgrade as of now. I did contact BlueROV support, and they told me not to worry about this. So I’m pretty easy as of now… Just looking forward to doing more ROV work… Here is some video from my newest discovered shipwreck… Skipsflakið „V“ (+1911) | DiveExplorer

Quickly as an additional thing to test, which may help, but could you try backdating your ardusub version to 4.0.3?
Using an old version of ardusub has its own separate issues, but considering your still using the old companion its should be mostly fine. I think its helped with the pixhawk on my machine - so it may be something worth giving a go. I’ve heard that the pixhawks can have a variety of different chips on them and maybe one of them is just not compatible with the ardusub version you have.

1 Like

It´s worth trying out… At least see what happens. Thanks for coming up with this idea.

Just for some context here, this is commonly caused by sensor drift while the vehicle is sitting still (e.g. on a bench/the ground, out of the water), especially if the sensor calibrations aren’t spot on for the position and environment it’s in.

If it’s only happening while the vehicle is still then it can be ignored, but if it’s happening during regular operation then it’s recommended to redo your sensor calibrations (making sure to turn the vehicle about all the axes during the accelerometer calibration, having it sitting still (e.g. not on a boat or floating jetty) during the gyroscope calibration, and not calibrating the compass close to large metallic objects/structures). If that doesn’t help then it’s possible there’s an issue with one or more of the sensors, in which case the flight controller may need to be replaced (or the sensors, if you’re able to source more and have the time, equipment, and skill available to rework the flight controller PCB).


Estoy configurando mi equipo y este error es muy recurrente ERROR EKF3 IMU1 FORCED RESET, cualquier ayuda es bienvenida, saludos.

Hola @fabianmnrov, bienvenido al foro :slight_smile:

I have moved your post here because it is on the same topic.

Please see my comment above yours to understand the issue :slight_smile: