Home        Store        Docs        Blog

Depth hold issue


(Oystein Skarholm) #1

Not sure if this is the correct location for this topic, but here we go.

During testing of the ROV I have ran into a rather peculiar issue. When pressing dive mode for depth hold the ROV sits perfectly still…down to 8 meters or so. Deeper than that, if I press depth hold,it will return to 8 meters before holding the depth. I tried to reboot and did the same again: Went down to 10,5m - 11m and pressed depth hold. The ROV immediately ascended to 8 meters and stopped. Any suggestion on how to solve his anyone ?


(Jacob) #2

Are you able to ascend and descend freely between 0~8 meters? Do you have the GeoFence option checked on the safety page?


(Oystein Skarholm) #3

Jacob
No problem do dive deeper in stabilize mode and manual mode. When pressing the depth hold button the ROV returns to 8msw and stays there. Pressing the depth hold anywhere between 0-8msw works fine, the ROV then stays exactly where it should…just not below 8msw. The depth fence is set to -100 - report only


(Jacob) #4

Uncheck the depth fence option, and you should be good to go.

I just fixed a bug in QGroundControl this morning where the Max depth value in that field was not set correctly, your maximum depth was probably set to the default of 10 meters.

If you do want to set the maximum depth in software set the following parameters:
FENCE_ENABLE: Enabled
FENCE_TYPE: Altitude
FENCE_ACTION: Warn Only
FENCE_ALT_MIN: -100m or whatever limit you want
FENCE_MARGIN: 0, or added buffer to stay away from limit

Note that the limit is only enforced in depth hold mode.


QGC update - How to
(Oystein Skarholm) #5

Thanks Jacob
I had the settings like you describe but the issue still remains. One more thing: When in flight mode, is the pilot suppose to be able to still adjust the depth with the stick, without having to go out of depth hold mode? I am not able to do so when in depth mode, but I would sure like to. ?


(Jacob) #6

Yes, this is the intended behavior. It sounds like something else is wrong. Can you please email support@bluerobotics.com so we may resolve this quickly. We can post the resolution here.


(Jacob) #7

Oystein purchased his ROV before December of 2016, and was running an old version of ArduSub. His issues have been solved by updating the ArduSub firmware on the Pixhawk.