Home        Store        Docs        Blog

Depth hold = depth down?!


(Richard) #1

Hi All
On recent dives with my BR2 I’ve been having some puzzling behavior-- depth hold suddenly isn’t “holding” anymore, it is instead making the vehicle descend constantly and fairly rapidly. I’m running the BR Rev6 build of QGC on Windows and ArduSub 3.5.3 (ad81760b). Depth sensor works fine, and the movement is not the result of joystick input (it’s calibrated just fine and other flight modes don’t show the same behavior). Anybody else seeing this?


(Heinz) #2

Hello Richard.

I had a similar scenario recently. I had added an externally mounted gps module so I could see the vehicles position on the surface. Whenever I would dive weird notification were coming in, such as a parameter not dating, and some magnetic interference problem. At that moment when I would go into depth hold mode, the craft would either dive quickly or go up quickly at an angle.
Since I suspected the gyros on the pixhawk were being magnetically interfered with, I disconnected the GPS module from the pixhawk and did a test dive and the craft worked perfectly. Depth hold mode worked perfectly as well as stabilized mode.
It sounds like the pixhawk has got some magnetic interference.


(Jacob) #3

Are your motor directions correct? Do you have a gps plugged in?


(Richard) #4

Motors correct, other flight modes are fine, no gps.


(Richard) #5

I have been doing testing with gps lately, and when doing so I have sometimes been getting ahrs-related error messages similar to what Heinz described. I do wonder if there is weird RF or magnetic stuff going on around my house for other reasons, but this depth-down behavior was the same when I was out at sea yesterday as it was at home.


(Jacob) #6

Magnetic field should not affect depth hold in general. Try switching the direction of the vertical motors. This is the problem 99% of the time. Otherwise, post your parameter file and a log.


(Richard) #7

Will do, thanks for responding.


(Richard) #8

Just thought I’d mention that I’m still having this problem. Will post params and a log file today or tomorrow.