Home        Store        Learn        Blog

Listing in Depth Hold or Stabilize flight mode

Hi all.

We have a Blue ROV2 that was purchased in March 2018. It’s typically used in the ocean for light commercial inspection work around British Columbia, Canada.
It has been great to use and has worked extremely well for our intended purpose.

However, about 6 months ago, it developed an issue.
Basically, the vehicle will list to starboard when in depth hold or stabilize flight mode. When we change back to manual flight mode, the vehicle will level out. And if we change back to depth hold, it will list again.
The artificial horizon seems to be functioning correctly and tracks the movement of the vehicle correctly.

The problem seems to be somewhat intermittent.
I have noticed this happening occasionally when we first start the dive, with a list of maybe 3-5degrees. But it becomes more apparent after 45mins or and hour into the dive where it will list 15 degrees.
Again, switch to manual flight mode and the vehicle with level out, then back to depth hold and it will list. The depth does not seem to effect the issue.

Maybe the time taken for the issue to get worse is related to the internal temperature or lower battery voltage?

The ROV is trimmed as level as possible and as close to neutrally buoyant as possible. We typically operate on 25% gain.

When this first started happening, per suggestions from Blue Robotics, we updated the software, and recalibrated the sensors.
All the thrusters seem to spin freely and feel the same to spin by hand. I’ve checked all the connections and all seem ok.

Does anyone have any suggestions before we go ahead and order new thrusters and ECS’s in a hope that will fix the issue?

Hi @Ben1,

Can you share a dataflash logs? That should help us understand what is going on.

Hi @williangalvani

Here is a datalog file from yesterday when we were testing the ROV in a tote of water to try and narrow down the factors relating to the problem. This is after the most recent updates. Seems after the updates, the datalogs have no time stamp?
If you would like one from before the updates, just let me know.

log_42_UnknownDate.bin (4.2 MB)

We spent a fair amount of time yesterday with with ROV in the tote trying to understand and replicate the problem, each time pulling the vehicle out and disconnecting the battery and restarting QGC. What we learned is, when the ROV first goes in the water and we arm the vehicle, it will operate corrected in manual flight mode. Typically, the first time we switch to depth hold or stabilize flight mode, it will function correctly.
If we switch back to manual flight mode, then back to depth hold, one vertical thruster will force the vehicle up and one vertical thruster will force the vehicle down. Some times this makes the ROV list to port and sometimes to starboard.
And if we switch back to manual flight mode, the thrusters and vehicle will function correctly.

Thanks

Hi @Ben1,

This looks like a tuning issue.

As the BlueRov2 standard configuration is naturally stable on roll axis, you can try setting ATC_ANG_RLL_P to 0. Or just take your time to properly tune it.

While it is not a fix, if this happens In-flight you could try to trim roll so it sits level.

@williangalvani Thanks for the tips.

The issue seems to have progressively got worse over time. Yesterday we tried resetting the default parameters and re calibrating the sensors, then went for a dive. As soon as we hit depth hold or stabilize flight mode, the vehicle went into a violent, continuous roll only stopped by switching back to manual flight mode.

The following warnings were also given.

Could this be a hardware problem with the Pixhawk as we have not altered any settings, other than the recommended updates? and if so, would simply replacing it solve the problem?

We currently have a project on hold until we can have the full functionality of the ROV back, Therefore are eager to to find the root cause and a permanent fix.

Thanks

Hi @Ben1,

This is a symptom of inverted motor directions. The Rov is trying to stabilize by applying thrust to roll right but the applied thrust is rolling left instead. Please see the Configuring motor directions of the documentation.

@williangalvani

Is it possible to alter the motor direction that is only applicable for depth hold or stabilize mode?

When in manual flight mode, the motor directions are correct in, when we thrust down, both vertical thrusters force the vehicle down evenly.

I can think of two possible issues:

  • Both your joystick throttle and vertical thrusters are inverted (which would cancel each other in manual mode)
  • Thrusters 5 and 6 are connected to each other outputs, which would cause the rov to be unable to control roll properly

Hi @williangalvani

The first of your two points was correct thanks. It seems in the process of the last updates and then resetting the ROV to factory default settings, we ended up with the two vertical thrusters operating in the wrong direction. With that corrected, the ROV does not go into a continuous roll any more, but it still does not function correctly.

When we hit Depth Hold, it "wobbles’ slightly back and forth from left to right. and then after a few minutes, it either goes into a continuous dive until it hits bottom, or just stops holding depth and begins to slowly ascend with the very slight positive buoyancy it has. When this happens, while still in Depth Hold, we can thrust up, but can not descend. When we switch back to manual flight mode, the ROV functions as it should.

And when we recovered the ROV at the end of the dive, we received a warning, EKF2. IMU1 forced reset.

Do you have any further suggestions on what could be causing these problems?

Hi @Ben1,

Can you share the last dataflash log?

This could be a bug, but I’d like to check the log to be sure.

Funny, today I tested my brov2 for the first time in water and had exactly the same issue as Ben is describing. In both depth and stabilised mode thruster 6 go nuts. Every else works fine, better then fine actually…:slight_smile: came to the forum to search if anyone has similar problem and saw this post. Will check tomorrow what Williangalvani is suggesting. Pretty sure its just a simple misconnection somwere.

Same for me and my BR2 heavy, after using the new Trim functions (shift + …) and return to depth old, then it goes down to the bottom … If I go ahead in stabilize mod then everything ok but not in depth old. So after using the trim, I disarmed and rearmed to go into depth old …

Hi @JeanBenoit, Can you also share a log? I’d like to make sure it is the same issue that @Ben1 had.

@Ben1 I noticed the issue in your log and I’m working on it.

1 Like

@williangalvani Sorry i’m not sure for the dataflash date, i try to find !!

@williangalvani Perhaps this one
log_5_UnknownDate.bin (5.9 MB)

My issue solved, pretty simple and stupid…:slight_smile: i did not have level on rov so in stabilised mode the motors were trying to level, increasing in power and then stopped when i tilted to straight horizontal. Not saying its the same issue as above, just saying…:slight_smile:

1 Like

Hi @williangalvani

That is good news that you have been able to identify what is causing this.
Do you have an idea of when you may have a fix? So that we can start scheduling some work that we have on hold.

Thanks

1 Like

Hi @Ben1,

We are working on a new release for companion with some bugfixes and I intend to focus on this Ardusub later, very likely next week.

Please get in touch if you are interested in helping me test the fix.

Hi @williangalvani

We were out to do some pipe inspection two days ago and ran into further issues with the ROV. All of the below has occurred while in manual flight mode with the latest updates.
Basically the compass and artificial horizon started freaking out and spinning around in all directions. Not long after, we received a warning of depth sensor error, and sure enough, the depth sensor values started fluctuating all over the place. It seems to be an intermittent issue as it kept happening randomly as we continued the inspection.

When we breaker for lunch, I recalibrated the depth sensor, but did not recalibrate the compass or horizon. These both still had green indicators next to them in QGC. And when not intermittently going crazy, where functioning as they should.
I have not yet had the time to open the electronics enclosure and look to see if this is a loose or broken wire yet, or do any further trouble shooting.

Could this possibly be related to our depth hold issue?

Thanks

Hi @Ben1,

I would really like to see a log of this dive! It seems that the EKF freaked out, but the depth sensor failing too leads me to think that something else is not right. What is your hardware setup like? Anything not stock?