Camera visualization problem in QGroundControl

I’m having problems to properly visualize the camera with QGroundControl. I’m getting an image like this:

So basically the video it is just in one thrid of the screen, with a black and white color. This happens on the 1280x720 resolution and below. If I put higher resolution, it does not show anything on the screen. On the BlueOS preview, the image is fine, the only problem is on the QGroundControl.

I’ve checked a lot of similar topics and also the troubleshoot for this case, but none of the solutions worked. The camera that I’m using is the one in the BlueROV. This issue happened when changing to the new Navigator with the retrofit tutorial. I’m using Ubuntu 22.04 and connectiing with the robot via the FanthomX interface. The robot has the official BlueOS, ArduPilot 4.1 and QGroundControl 4.2.4.

What have I tried so far:

  • Plug another camera usb in the robot - same problem
  • Change the usb cable from camera to pi - same problem
  • Change the tether interface connection to a more powerfull USB port - same problem
  • Increase MTU - same problem
  • Tried different version of QGroundControl - same problem
  • Change FPS and resolution - same problem
  • Change to different UDP ports and to RTSP - same problem
  • Change the scale for the image in QGroundControl - same problem but with stretched image
  • Check network speed - it is about 65mbps

I probably tried more stuff that I don’t remember as well… But no luck. I normally find solutions online, but this one has cost me more than a day. If you have any suggestions of things that I could try, please let me know.

Yeah, seems like too many bugs in the software. I get a better through-the-camera than you, but cannot record any video, when I hit the round red record button on the right. Can you record?
I’m curious what your error log shows? You can generate it by going to Console in the Application Settings menu.

I also cannot record videos. I’ll get the log and post it here on Monday. Thanks.