BlueROV2 R1 Camera not detected after upgrade to BlueOS

I have a BlueROV2 R1 (stock build, no additions) that I just upgraded to the latest version of BlueOS with a Pixhawk controller updated to Pixhawk 1 - 4.10. After updating to BlueOS I have lost the camera feed (everything else seems to be working). I have gone through the troubleshooting steps other than pulling the RPi completely.

When I log into the web interface and click on video I just get a message “No Video Devices Available”.

Is this maybe a driver issue for the older units/cameras? I haven’t been able to find any instructutions about that.

Thank you for any help.

1 Like

I am bumping this - I see others are having trouble getting video to load in QGroundControl - wondering if there is a common problem on older BlueROV2 units?

1 Like

Hi! Just pumping up the topic here since we are at least three with the same problem after the same upgrade. @UBICA here it is another case like ours. @EliotBR suggested to update qgroundcontrol to 4.2.5, did you try this already? I still didn’t have the time to test it.

Here are the link to the topics that are similar to this one:

I hope this issue gets more attention, since this happened after we spend money in something that was supposed to make our lives easier. I’m glad that @EliotBR gave an advice, but from the commits that I saw in qgroundcontrol repo I’m quite skeptical that it will change something. As soon as I test this, I’ll comment here. @UBICA can we centralize the comments for this issue here? It has a better tittle and it is more recent. By the way, any updates from you two @UBICA and @mdares ?

1 Like

@EliotBR I updated the Qground control, still the same problem. In the preview of the BlueOS is fine and in the QGroundControl it isn’t.

1 Like

@bajaMike you said you were curious about the logs, here it is:

Just when I start QGroundControl this appers:

Do you guys have more suggestions?

1 Like

No updates here - I am hoping to put a full day into it in the coming week, but am honestly past my depth in troubleshooting. I think disassembly and trying to just get the RPi and the camera working standalone is the next step for me.

1 Like

Hi @mdares, welcome to the forum :slight_smile:

Apologies for the delay on this.

A couple of questions to clarify:

  1. Can you specify which camera you have?
  2. If it’s a USB camera, does it work / is it detected when you connect it to a normal computer (e.g. in your operating system’s Camera application)?

I believe there’s an issue we’re investigating at the moment of some of our USB cameras dying due to a Raspberry Pi firmware problem, but I’m not certain if that’s what you’ve run into here.

@EliotBR I am back at work this week and will find some time to answer your questions. Sorry for the delay. I know the connection between the camera and the Pi is by a ribbon cable.

Ok, that’s a Raspberry Pi camera (not a USB camera), which is not supported in BlueOS 1.0 (the latest “stable” release).

If you turn on Pirate Mode you should be able to update to a recent BlueOS 1.1 beta version (from the Version Chooser), after which there’s a new settings icon in the bottom right of the Video Streams page where you can enable Raspberry Pi camera support, then reboot BlueOS and the camera should be detected.

Note that there are quite a few interface changes from 1.0 to 1.1, including a different way to control Pirate Mode (so that you can turn it off once you’ve updated).

@EliotBR So this all seems to have worked (I was able to enable legacy mode) but getting this message when I hit the video streams page:

And QGroundControl does not connect to video either - everything else seems fine.

Can also confirm:
I was able to login to the host PI OS and take a photo with raspistill

Just got this message:

Last question - if I opt to try out the USB Camera - do I need to replace the motor mount too?

This is about the streams you have configured in BlueOS, and the way you’re connecting to BlueOS. Is the Raspberry Pi camera appearing as an option in the Video Streams page (in mine it appears as “mmal service 16.1”), and is there a stream configured for it?

Our Low-Light HD USB Camera does not have the same mounting hole locations as a Raspberry Pi camera, so they cannot use the same mount.

If you have access to a 3D printer you can print a mount for the USB camera, but we do also sell an injection moulded one that comes with the relevant screws, if that’s preferred.

I’m sorry for delay in reply, but today we were working on field and issues with the camera arose again…Everything was working yesterday but today suddenly the problem with the camera came up again. We are wasting time and money. I believe that @Bluerobotics has to give some answers since the last few emails the assistance didn’t even consider us.

1 Like

2 posts were split to a new topic: USB Camera Unexpected Failure

@UBICA do you have some other email we can respond to? I’ve been told our support team has responded to multiple emails that didn’t seem to get through, and from the emails I have access to in our system it seems there was a similar issue last month between your email address and multiple people in our sales department.

Feel free to send an email address as a private message to me here on the forum, and I can pass it along to our email support people.

@EliotBR I sent you a private message.
Thank you in advance

I ordered your USB Camera and reverted to BlueOS1.01 and everything seems to be working good with the camera now. Thank you!

Since this is happening with multiple people, I think it would be nice for you guys to share the solution that you found through private messages @EliotBR and @UBICA. I stopped trying to fix this issue, but when I come back, it would be nice to know if there is a common solution.

Hi Matosinho, sorry for the delay.
We changed the camera and the video streaming started working again. One day everything crashed again and after 2 hours it started working again. At the moment we have about a 1.5 second delay in streaming but at least we have been able to get the work done. We are now trying to figure out why there is a delay and why the streaming sometimes crashes unpredictably. We will try to reinstall the newly released software versions and see if the problems are resolved. We will update you as soon as possible.

1 Like