Home        Store        Docs        Blog

Camera tilt doesn't work

Hi,

I mounted the BlueROV2 in heavy configuration, so I moved the connector of the servo camera to the auxiliary connection 2 of the pixhawk.
In QGroundControl, I configure the frame with the heavy configuration, but the tilt of the camera does not work.
If I change the functionnality for those buttons (for example open/close the gripper, it work)
Is there a setting to change in QGC for camera ?

I have the latest version of QGC (3.5.6)

thanks for your help,

Hi @AWDRONE,

A couple things to check:

  1. Have you loaded the BlueROV2 Heavy Parameters as shown in this step instead of just simply changing the frame?
  2. Is the tilt servo plugged in correctly? If it is upside-down, it won’t work.
    “Unplug the camera tilt servo from Pixhawk Channel 8 and replug it into Aux Channel 2 with the yellow signal wire oriented toward the bottom of the Pixhawk.”

Hi,
Yes I reboot the vehicle, on the page http://192.168.2.2:2770/system
Her is photos, to show how camera is connected. It seems to be correct.


Your wiring looks correct, thanks.

These are the default settings for the camera tilt on AUX2 (= Channel 10):

You mentioned this in your first post:

If I change the functionnality for those buttons (for example open/close the gripper, it work)

Can you show me what your joystick/button setup menu looks like? If you have a gripper, it should match what is in the Gripper Installation guide.

Hi,

For the camera setup, I have the same parameters.

For joystick parameters, here is my configuration :

with this configuration, gripper is ok, but camera tilt doesn’t work.
If I affect gripper to the main function for buttons 9 and 10 and shift function for camera tilt, it’s the same result : gripper is ok, and camera tilt doesn’t work.

I have a logitech F310 joystick.

Interesting. It may be one of two things:

  1. A bad channel out on the Pixhawk. Can you try plugging it into AUX 4 and then changing the camera tilt output channel to Channel 12?
  2. The servo may be dead. I haven’t seen that particular issue lately, but I won’t rule it out. Has the servo ever worked before?

Hi,
I tried putting camera into AUX4 and changing output channel in QGC : no result.
If I put in on channel 8 (default channel), it doesn’t work either.
The servo has never worked before, whatever the channel

Hi @AWDRONE,

Do you have the 5 V power from the BEC plugged into the servo rail? I believe the default port is SBUS.

-Adam

Hi,

How to check this ?
Sorry, but I don’t understand the acronyms : BEC, SBUS.

In a previous post, I put photos to show how the camera was connect.

Hi,

I founded this post:

The problem seems to be the same as mine, but I don’t understand how to check that the servo is plugged to power.
How to check that?

If you have a multimeter, touch the positive probe to an used power output channel (anything but the “RC” channel) and the negative probe to a subsequent ground output. You should read 5V if the servo rail is powered.

@AWDRONE You should see a regulator (red 5V and black ground wires) plugged into the slot marked SB.

Hi,
I don’t have regulator plugged into the slut marked SB.
All of my wires are plugged in somewhere and I have no wires available to plug into this slot.
From the camera servo, I’ve only a black-red-yellow wire, who is plugged into the AUX2 slot.
Where should the wire to connect to the SB slot come from?
Here is some photos to show how wires are plugged :



You should find this 5V regulator installed next to the Fathom-X board on the other side of the electronics tray:


One of the 2 output plugs goes to the Raspberry Pi, that’s what this is:
image
The other one should plug into the pixhawk servo rail here:
image

1 Like

Hi,

OK it works !!
But the second was not plugged and he was hidden in the other wires, is it normal ?
why is he not plugged by default ??

Thanks a lot for your help,
Nico

That’s great! Glad to help.

Both of those are supposed to be plugged in already by default. If this is a newly assembled system then that might have slipped by during our assembly. If that’s the case then sorry about that!
If it was working previously then it’s possible it got loose sometime when you were doing the other wire connections.

1 Like

Hello Jacob. i am having the same problem with setting up my gimbal and can not get the tilt to work. i have just checked my 5v regulator and it only has 1 plug attached that is connected to the raspberry pie but nothing to connect to the pixhawk.

Does the 5V regulator look like this?

@danj81 @dgudiel

Older ROVs shipped with two individual 5V regulators. One to power the pi and one to power the pixhawk servo rail for camera tilt. Those regulators look like this:

image