Home        Store        Docs        Blog

Camera Tilt not Working


(Grover) #1

Hello,

 

I have assembled the BlueROV2 and everything seems to work so far except the camera tilt.

 

I have tried plugging into CH8 and CH10 and setting the output channels to CH8 and CH10, while keeping the input Channel as CH8 (configured in the parameters tab as camera_tilt). I tested the servo on a different platform and confirmed that the hardware for the servo works properly.

 

I am using QGround Control (version October 19, 2016) and Windows 7.

 

Does anyone have any suggestions?

 

Thanks!


(Rusty) #2

Grover,

Did you leave one of the 5V wires in the ESCs to provide power to the servo? I would check to make sure the servo is getting power.

Sounds like the parameters are set up correctly.

Let me know.

-Rusty


(Grover) #3

Hi Rusty,

 

Thanks for your quick reply!

 

Yes, I left one 5V wire from the ESC and I did not modify the camera tilt servo wires (signal, 5V, and GND). I checked for voltage coming out of the channel that is connected to the servo (both channels 8 and AUX 2) but there is no 5V. Should 5V power be coming out of the servo constantly?

 

Thanks,

Grover


(Rusty) #4

Grover,

There should be 5V at the servo plug to power the servo. That 5V is supplied by the ESC that has the uncut 5V wire, so make sure you power up the ESCs when you test this. If you’re not seeing 5V, then please double check the servo wires and make sure that one of them is providing power.

-Rusty


(Grover) #5

Hi Rusty,

 

That fixed it, thanks!

 

I double checked to confirm that the 5V was still connected to one of the ESCs, but they all were disconnected for some reason. So I plugged one back in and tested it and it works perfectly now!

 

Thanks again,

Grover


(Rusty) #6

@Grover - Great! Glad to hear that it’s working.