Home        Store        Docs        Blog

The tilt of the camera does not move


(DAISUKE IDE) #1

Currently, CGC V3.2.4 Rev 6 and Ardusub V 3.5.4 are all used as default parameters.
I inspected Tilt 's servo and Pixhark by itself, but it is normal.
What should I check my settings?


(Matt) #2

Was it working previously?
Or is this a new build?

Have you checked that the Aux port on the pixhawk lines up with the servo channel port on QGC?
Are you hearing any sort of sounds or attempts to move by the servo itself?


(DAISUKE IDE) #3

Yes, before that it worked normally. I had thought that it is due to the failure of the H / W. I exchanged Pixhark with servo, but the problem did not solve it.
Also, when changing Light from 7CH to 8CH, light worked normally.
The servo was connected to the servo tester by itself and the operation was no problem.


(Matt) #4

Sorry, to clarify you changed out the pixhawk and it made no difference?
Have you changed out the servo itself?


(Jacob) #5

The servo rail needs an independent +5V source, usb will not do it.

We use a UBEC labelled “hobbywing” to supply power to the servo plugged into the port “SBUS”.

This UBEC must be plugged into any available port on the servo rail EXCEPT “RCIN”. This one will not power the rail.


(Matt) #6

If you changed out pixhawk and made no difference, and you checked the servo on a tester working fine …
And like Jacob suggested, you still have your power on the rail? It hasnt fallen off?
Do you have anything other than the lights on the AUX channels?

If all this is fine …then it must be a software setting has changed somewhere.


(DAISUKE IDE) #7

Thanks guys. It worked on supplying 5V.
But where does everyone supply it?


(Jacob) #8

We ship the rovs with 5V supply plugged into “SBUS” port.


(DAISUKE IDE) #9

I changed ESC to a new type at the timing of software update. The old type ESC had built-in BEC, but the new ESC is NON-BEC. As a result, the supply of 5 V ceased and the Tilt servo did not operate. I understood logically.
Thanks!