BlueBoat NavLight LED shining without flashing

Hey all,

Sorting out some Blueboats and it looks like one of ours has the top LED that is stuck on continuous (supposedly loiter mode). However, even if I change to other modes (simple, manual…) the LED continues to stay on continuously. Is there a fix for this? Aside from using more power, I think this is less visible and also the light gets quite hot to the touch!

Hi @Vincent -
I would guess that the lua script that controls the light flashing is not installed correctly! If you run the vehicle setup wizard again, this should be completed - apologies for the hassle.
You can do this from the BlueOS settings gear in the lower right - pleas make sure the system is connected to a WiFi network with internet before attempting. If that still doesn’t do the trick, it is possible to download the correct file and put it in the correct location manually!

Ok, so trying to rerun the vehicle wizard. I’ve got a connection and that’s confirmed in BlueOS, I can choose vehicle, but then gets stuck in the ‘customize’ step. It just says ‘Loading scripts’ indefinitely, with no option to continue, saying ‘unable to load parameters’. Any ideas? How could I load this directly?

Update: I’ve updated both BlueOS and Autopilot firmware to latest (1.2.5 and 4.5.2, respectively) and tried again. Now I’m getting a clear ‘Failed to load scripts’ error and can’t proceed.

This is weird - I just tried and it worked fine for me, so it might be worth trying again, or might be some kind of region or connectivity issue.

This is the file in question, and it needs to be in configs/ardupilot-manager/firmware/scripts/ (which you can do using the File Browser). I’d recommend restarting the autopilot after adding that, to make sure it gets loaded.

If that doesn’t help then there might be an issue with how the light is plugged in, or with the light itself / its cable.

Since we can’t seem to replicate this, it would likely help us find the issue if you can provide your System Logs (from the same window Tony directed you to earlier) :slight_smile:

1 Like

I had the same issue with Ardurover 4.5.2. I downgraded to 4.4.0 and it resolved the issue. Let me know if the LUA script fixes the issue.

1 Like

Connectivity could be an issue, I’m connected via uni wireless networks that are notoriously odd, but on the other hand using this same connection I’m able to download and update the firmware without any issue, so I’m not sure it’s the cause. I’ll try and record this log to see if you can pick it up, and will also see if the previous firmware suggested below addresses the issue.

Ahh, I see - that could be a firewall issue, perhaps?
The firmware gets downloaded from firmware.ardupilot.org, whereas the parameters are fetched from bluerobotics.github.io, so it’s possible the parameter source is being blocked by your network.

You could test that by either:

  • pinging each server from the BlueOS Terminal and seeing whether they both respond
    • e.g. run ping firmware.ardupilot.org, and see whether it returns some bytes, or hangs / gives a warning (press CTRL+C to stop the process), then do the same with ping bluerobotics.github.io
  • trying a different network
    • e.g. a mobile hotspot

I have updated to Ardurover 4.5.4 and BlueOS 1.2.6.
The Blueboat led is still stuck ON.
I can ping ardupilot & blue robotics as mentioned in your previous post.

Any fix to turn the light off or have it flash without downgrading ardurover firmware?

Cheers

Hi @CA_BlueBoat / @Vincent -
I had intended to link to this thread in my reply - to summarize, download this lights.lua file and place it in your /configs/ardupilot-manager/firmware/scripts folder with the BlueOS File Browser (need to be in pirate mode for this.)


The latest version of the lights.lua file can also be found here.
Once you restart the autopilot (under Autopilot Firmware, or via the power button in the lower left of BlueoOS menu) you should have the light following the normal blink patterns.
If the issue persists, please verify you’ve loaded the default BlueBoat parameters via vehicle setup / config tab.

Hi Tony,

Thanks for the great instructions. the lights.lua.txt you linked did not work for me (I did remove to .txt on the file extension). but the one linked on github worked just fine.

Cheers

1 Like

Hi Tony,

My blueboat LED Light is stuck ON and I do not see lights.lua in my scripting folder.
Any chance you could send that script so I can stop being blinded by that LED?

Cheers

Hi @CA_BlueBoat -
You can find that file here.

Did you recently update? Running the vehicle setup wizard (from the gear button in the lower left of BlueOS) should also install this script in the correct location.

Thanks for the link.

I did a totally fresh SD card install on the boat ~2 months ago. it was working fine on an earlier version of ardurover, but at some point I upgraded and it was stuck ON. I just noticed that there was no script in the folder.