Home        Store        Docs        Blog

Ardusub in Advance electronic package

Hi guys,

I Have a full advance electronic package but i cannot get the ardusub to work on it I´ve follow these steps:
https://www.ardusub.com/getting-started/installation.html

Any ideas?

Regards
MHobson

Where are you stuck? You should check out the troubleshooting section.

Hi Jacob,

I believe it was a wiring problem but now I´ve been having troubles with the SD cards. None of the SD cards let me flash with etcher is showing me E: Locked, I´ve tried over 3 different cards but nothing. any ideas?

Are you using an sd card adapter?

There is a little switch that you might have to move.

image

Hi Jacob,

Im using an SD card adapter and I´ve tried over 3 different SD cards, and few tools to low level format with no sucess. The error is the disk is protected against writing.

Did you try to flip the switch on the adapter? It sounds like your sd card adapter is broken. Do you have another one?

Hi jacob,

I did actually i bought 2 new adaptes and 1 new SD and had the same problem. Right now i found one old adapter which was sent with the advanced elect packages like 1 year ago by BR and its working…

IDK whats the problem with the new adapters.

Hi JAcob,

Now i flashed the SD card and inserted it on the RPI, i followed the steps for the pixhawk and its working just great when i connect directly to the computer.

But when i try to connect to the QGC through RPI, Fathom X tether interface i cannot get connection to QGC any ideas? wiring is as following:

Fathom X surface: + - to Fathom x in vehicle + -
Fathom X surface ethernet cable to PC and USB type C to PC
Configured 192.168.2.1 and 255.255.255.0 in PC

Fathom X in vehicle: Ethernet cable to RPI
RPI in vehicle: USB to pixhawk
RPI in vehicle: USB to camera
RPI in vehicle: Power on the last 3 pins through ubec
Pixhawk in vehicle: ESC 1 to 6, power through new power supply LED in the middle Blue and yellow intermitent.

I Hope I have given you enought details

JAcob,

NVM solved we missed the power supply to the fathom x in the vehicle.