Home        Store        Learn        Blog

Xbox controlled not mapped by QGroundControl

Hello there,

I’m trying to calibrate my joystick as indicated in the software setup tutorial, but the QGroundControl doesn’t detect the xbox controller, and it indicates that “it is not mapped”.

However, If I do a jstest from the console, it correctly detects the controller in js0.

I’m using Ubuntu 14.04 and the last version of QGroundControl, which I downloaded from your software guide this monday. I used xbox driver xboxdrv, first with version 0.8.5 and now with version 0.8.8 (which is the latest) but the problem remains. I’ve used a wired xbox360 controller and also a wireless xbox 360 controller, obtaining no different behavior. I also tried all the different TX Modes without noticing any change.
Below there is a capture of my screen showing the problem.

I previously used an older QGroundControl version, and it detected my joystick correctly! However, I’m not using it as it gave me other different problems.

Any guess of what might be happening? Do you recommend any other xbox driver?



Ok, the xbox360 wired controller should definitely work (you need to click the Enable checkbox), so not sure what’s up there. You should not need to install any additional drivers in Ubuntu, it ships with xbox360 drivers. I found a bug just last week with the wireless receivers. The wireless receivers present 4 joysticks to the OS (regardless of how many were actually connected, and QGC always picked only the 4th joystick (js3). I’ve made a fix to display all 4 joysticks in the dropdown, but the joystick buttons are mapped to different numbers than usual. I need to do more testing before I merge this fix for everyone, in the meantime you can get QGC with the fix here.


Hi Jacob, thank you for the quick answer
The fix works! I don’t know what could be causing the problem, but it is solved with your fix!

Thank you very much :slight_smile:

Hello again Jacob

I’m posting it here since it is (I think) a related issue.

The xbox controller is mapped with this last release of QGroundControl, but the right joystick is not well mapped. I tried with different joysticks to check if the problem was in the joystick, but the same problem occurs.

When I move the left joystick up and down, the 2nd axis (which appears associated with the lateral attitude control) works fine.
However, when I move it left and right, the forward attitude control doesn’t move at all. Looking at the 4th axis, without even touching the joystick, it appears deviated to the right, and when moving the joystick it only moves to the center of the axis or the right.

As I said, it couldn’t be a hardware problem since I tried with two different joysticks, and both gave exactly the same problem

I’m attaching a video that shows the mentioned behavior. In the video I first move the joystick Up and down and then left and right.

What can be causing this?
Unfortunately, I won’t be able to try it on water until next week, to see if it affects its behavior on water.

@olaya I’m sorry, it’s not entirely clear what is going on here. On the ‘Axis Monitor’ on the right hand side of the screen, 0-3 should be the joysticks, and 4 and 5 should be the triggers. Is this what you observe? If not, then something weird may be going on. Can you take a picture of your wireless receiver and controller?

The left joystick moves the ‘Axis Monitor’ 0 and 1
Moving the right joystick up and down activates the axis 2. When I move it left and right, it activates the 4th axis, not the third.
The 3rd axis doesn’t move at all with any joystick.

The triggers activate the buttons 4 and 6 in the ‘Button monitor’.

If I try to calibrate the joystick, when it asks me to move the right joystick left and right I cannot continue the calibration because it doesn’t detect any movement!

The controllers are the ones in this picture. Both give the same problem. They are Xbox controllers.

UPDATE: I tried with the same hardware and installing QGroundControl in windows and here it works fine. So it has something to do with Linux version… or maybe the drivers

Yes Olaya, I think your xbox driver is the problem. Ubuntu ships with built in drivers that should work correctly. Did you install another driver?

Hello Jacob,

I had the xboxdrv 0.8.8 installed in Ubuntu 14.04
I downgraded it to version 0.8.5, which is the default version for Ubuntu 14.04, and it solved the problem!!!

Thanks for everything :slightly_smiling_face:


Hi Jacob,

I can not use the link that left on the solution with the QGC that detects 4 xbox controls, can post again?

Hi @Igor, this was a temporary solution that I uploaded. Right now you should work with the latest release here. Let me know if you have any problem with it.