Home        Store        Docs        Blog

Wiring the BR2 PIXHAWK


(Oystein Skarholm) #1

Hi all
Just want to confirm with you guys before I get to the point of starting up the ROV.
I have wired the ROV with 8 thrusters as per heavy config set-up, using the pixhawk ch. 1-8
In addition to this I have the following setup in the Pixhawk aux.

  1. Signal plus power for usb camera servo in aux 1
  2. Signal plus power for analog camera servo aux 2
  3. Signal for the grabber in aux 3
  4. Signal for Lumen light upper quad in aux4
  5. Signal for Lumen light lower quad in aux5

Does this seem ok? Do I have enough buttons to control everything?

Is it possible to connect QGC to the electronics before the thrusters have been connected - To check the lights, gripper and servos ?


(Kevin) #2

Hi @SDI, Here’s the reference wiring diagram for the Heavy if you wanted to check your stock set-up: BlueROV2 Heavy Wiring Connections

If you are going to use AUX 5 for a PWM OUT channel, then you will need to change the parameter BRD_PWM_COUNT to 6 so you have 6 PWM outputs instead of the default 4 PWM/2 GPIO. Reference: ArduSub Auxiliary Pin Config

From a button assignment and operational standpoint, you are going to need to use the “Shift” function quite a bit and reassign some other functions (Input hold, camera mount center, etc).

Yes, you can connect the electronics and test in QGC before you have the thrusters connected, but you will need to do a sensor and joystick calibration first.


(Oystein Skarholm) #3

Kevin, thank you for the Pixhawk link.


(Oystein Skarholm) #4

I tried testing the gripper but was not able to get it working.
The signal for the gripper is connected to aux 1 and for tesing purposes I have assigned buttons 9 and 10 for testing.
Buttons are assigned to servo 1 min/max momentary See figure below.


I
In brd setting I have changed the board pwm count to 6, ref below figure.
Any idea what I am doing wrong ?


(Jacob) #5

Do the autopilot and the gripper share a common ground?

It should work in this configuration, double check you have it connected to the SIGNAL pin on the servo rail, and there is power for the gripper. Try to reboot the autopilot to make sure settings are committed.


(Oystein Skarholm) #6

The Gripper and autopilot runs from two separate power sources, sort of:
A 24volt supply is reduced to 12v through 2 off converters, 5Amp each. The light channel works with the lights being connected directly to the 24volt supply and the signal through the pixhawk, via one converter and one UBEC. Please see below sketch.

The light works but maybe the two dc converters separates the grounding between the two 12v supplies,


(Jacob) #7

Try to connect the gripper signal to the pin that the lights are currently on. Does the gripper move when you push the buttons for the lights?


(Oystein Skarholm) #8

Nope, tried that


(Jacob) #9

It sounds like a problem with the gripper then. Do you have a servo tester or thruster commander?


(Oystein Skarholm) #10

Unfortunately no.
But I will give it a go to let the gripper and PixHawk run from the same 12volt supply just to make sure that this double supply is not the reason. The lights and signal is only separated by 1 off 12v supply as the light are connected to the 24v supply.


(Jacob) #11

Have you worked with this unit before? Was it working previously or is it dead on arrival?


(Oystein Skarholm) #12

Never tried it before, it`s part of the new build.


(Jacob) #13

Do the lights show activity if you plug them into the AUX 1 pin and press the buttons for servo_1?


(Oystein Skarholm) #14

When I connect the lights to signal on aux1 and press servo _1_min_momentary the light dims down to zero - fast
when pressing servo_1_max_momentary the light go to max - fast

image


(Oystein Skarholm) #15

I tried to connect he gripper to the same 12v source as the RPi and Pixhawk. Still no reaction in the gripper.
The light is on approx 50% when connected to the same aux out and same power supply. When pushing MIN, the light dims to zero. When pushing MAX the lights goes to max. Looks like a dead gripper to me.


(Jacob) #16

Please contact support@bluerobotics.com to arrange a replacement.


(Oystein Skarholm) #17

Will do.


(Oystein Skarholm) #18

Jacob
I continued to assemble the wires as I figured out that the problem with the gripper was most likely inside the gripper. I have connected the motors now and a new strange bug is arising. When I power up, al the beeps and flashing lights seems to start as normal. QGC announces communication regained. But then, after just a few second, communication is lost ?? Any idea what may cause this ?