Home        Store        Docs        Blog

Wifi/Internet Sharing Issue

(Mark Langille) #1

One other issue ran into yesterday at the test tank was we couldn’t get the BlueROV2 to connect to QCG until we had a wifi connection. Testing it here in our shop today same issue, if we disable wifi or Internet Sharing it won;t connect.

Assume this is some odd setting we have as having wifi and sharing seems like not an option.

I must be missing something here to make this work with just the Ethernet to the Fathom X?

(Rusty) #2

@schoonerlabs - We have this issue too on Mac but it only appeared recently. I think it is a QGC bug. I’ve been able to avoid it by turning off the Wifi adapter completely.

I’ll bring this up again to the main QGC developers to make sure it gets fixed.


(Mark Langille) #3

Ok thanks, so I’m not going insane :slight_smile:

Yes it seems like a QCG issue of some sort. I’ll try to disable the adapter and see if that works here as a test.

(Paul) #4

I wonder if it has something to do with qGroundControl getting map info via the internet? I don’t think it buffers maps locally by default.

(Mark Langille) #5

That was my thought as well re the maps.

(Rusty) #6

I think it has something to do with the fact that we are using a UDP connection to mavlink. Most of the drone guys use a direct serial port connection. I’ve tested it that way and it works just fine without internet. It also only seems to affect Macs. I think it has something to do with the network adapters on the Mac.

(Mark Langille) #7

How did you turn off wifi? Unless I have an active wifi connection I cannot get it to connect. Tried turning it off, disabling it etc.

(Rusty) #8

@schoonerlabs - I’ll try this out again today and see exactly what I did.

(Mark Langille) #9

I did find a work around, not ideal but works, basically on your Mac create a wifi network then it seems to connect ok. Seems like it needs some sort of secondary network for it to work properly even though it has no Internet access.

(Patrizio) #10

Hi there, same issue here, QGC wont talk with ROV if some WiFi is not accessible. Any update for a solution?

(Rusty) #11

Hi Patrizio,

Can you confirm that you’re using a Mac as well? What version of QGroundControl are you using? You can find the version number in the top menu bar of the application.


(Patrizio) #12

Hi Rusty,

yes MacBook Air (13-inch, Late 2010) and QGC Development Head: f88922d 2016-11-27 15:02:16 -0800

I am gonna try again today providing a connection via my mobile phone. I suspect it might work but a more robust fix will be nice.


(Fredrik) #13

Hello :slight_smile:
Was there any fix to this problem ?
I’m having the same problem. Got a mid 2015 Macbook Pro, and i have tried many different Qgroundcontroll versions, but same problem.
Tryed to deaktivate the WIFI on the computer but that dont work.
It seems that i have to have WIFI connected to get the ROV to connect thru Ethernet.
In big need of a helping hand.
Thanks. :slight_smile:
Best Regards
Fredrik from Norway.

(Jacob) #14

Hi @fredriknico,

Can you please tell me:

  • QGC version
  • OS version
  • Computer model

(Fredrik) #15

Thank you for reply :slight_smile:
Im using Qgroundcontroll :c728d58 2017-06-24 .
But i have tried a newer version but the same problem occures.
My mac OS : 10.12.4 .
Computer model is MacBook Pro (Retina, 15-inch, Mid 2015).
We have tried a lot of different versions but cant get a round the wifi bug.
This is very problematic for us.
Thank you

(Jacob) #16

Please turn off the internet sharing settings on your Mac, and it should start working again. I have update the setup instructions to remove this step, as it is no longer necessary.