Water Linked DVL A50 Support

Hi @hub,

Please try the dvl branch again. We updated it to fix this issue.

1 Like

I has also met the problem. The reason is some python module has not be installed. Maybe you should Install update scripts manually.

I’m using a development version of QGC for my BR2 which is working well with the DVL A50. Where could I get this version to install on another PC?
image

I’m integrating a DVLA50 into a BR2 but I can’t get the vehicle to go into Position Hold mode.

I’ve previously integrated a DVLA50 with help from BR Engineers so I have a record of the settings from the vehicle it was working on and the .params file
2021-05-19 System Setup Page.pdf (65.6 KB)
. Last time it was suggested I use Ardusub version 4.1 but I can’t remember where to find it - Is there a link available?

The Companion Software Status version is currently “revert-point” - I haven’t seen this before . How could I update it to version 0.0.21-30-g5cafdde ?

Things that are working:

  • dvl-service is listed under Active Services.
  • Rangefinder is working.
    Thanks in advance

Pre-built ArduSub versions are available at the ArduPilot firmware site, which I got to via the ArduSub downloads page (for future reference). 4.1 is beta, so you probably want this.

I’m not certain how to cleanly install companion to a specific commit, so I’ve asked that internally and you’ll hopefully get a response soon :slight_smile:

@EliotBR Thanks for your help. I had navigated to the beta download page but I missed the firmware-verion.txt file so I didn’t know what version it was.
My problem is that I can’t flash the Pixhawk through the System page so I had previously done it by plugging it directly into my laptop and using the Firmware Setup utility in QGC, but that will only do the latest stable release.
When I attempt a Pixhawk Firmware Update through the system page, either by clicking on Beta, or uploading ardusub.apj it fails:

Flashing Pixhawk…
Loaded firmware for 9,0, size: 845608 bytes, waiting for the bootloader…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
attempting reboot on /dev/autopilot…
Timed out trying to catch bootloader!

Hi @gcelec ,

Sorry, I’ve been pretty busy. This issue should be fixed on companion 0.0.26. unfortunately the dvl branch doesn’ t contain these changes yet. We’ll try to rebase the dvl branch early next week.

To get Ardusub 4.1, clicking the “beta” button in companion or qgc (if plugged directly to the pixhawk via usb) should do.

We have a dvl section in ardusub.com with instructions. Please let us know if you run into issues following those, so we can fix the docs :slightly_smiling_face:.

1 Like

Hi @williangalvani - no worries - I know how busy things get and appreciate your help. Here’s what I’ve done this morning:

Now Companion doesn’t recognize the DVL at http://192.168.2.2:2770/waterlinked and it’s not listed as an active service ( I did have those previously).
DVL IP address settings are the same as previously.

I have the same issue installing it from git. Orientation buttons and nothing works. Im

Im updated it from 0.0.28 → DVL

Ardusube 4.1.0 beta.

I have also tried to downgrade to 0.0.23 with same result.

Get this error when i try to start it manualy
pi@rov:~ $ ./companion/services/waterlinked/dvl-a50/main.py
Traceback (most recent call last):
File “./companion/services/waterlinked/dvl-a50/main.py”, line 7, in
from dvl import DvlDriver
File “/home/pi/companion/services/waterlinked/dvl-a50/dvl.py”, line 6, in
from mavlink2resthelper import Mavlink2RestHelper
File “/home/pi/companion/services/waterlinked/dvl-a50/mavlink2resthelper.py”, line 1, in
from companionhelper import request, post
File “/home/pi/companion/services/waterlinked/dvl-a50/companionhelper.py”, line 2, in
import requests
ModuleNotFoundError: No module named ‘requests’

1 Like

I’ve been holding off on upgrading until I know I have time to fix bugs.

There is a conversation in this thread about the affects of upgrading to Companion 0.0.28

I installed the DVL service according to “option 1” from this link
https://www.ardusub.com/developers/dvl-integration.html

Then I upgrade from 0.0.24-15-g33651de to 0.0.28-14-gee0a5df from git section selecting DVL according to “option 2”. This seems to worked perfectly. It connected with no problems.

Hi,i have a waterlinked dvl a-50,but when integrated with bluerov,I am using ARDUSUB version 4.1.0,The position_hold mode works, but the system says the depth sensor is not connected, does anyone know why this is.

Hi @octopus,

Thank you,very cool! Everything work well now !!!

1 Like

Hello,

I am using the new beta companion and currently updated to beta.15. I am trying to integrate the DVL to it but am having difficulties. I saw the page on the docker implementation saying I need to ssh into the raspberry and run code, but I do not know how to do so. Is that through the companion software itself? If so where?


Also At the end of description it says configurations steps can be found through “available services” But I do not see that tab anymore on my software.

I do have access to the DVL separately through static IP I set to what it recommends in integration page. But from there I do not believe is connected to the companion software. Is there any other step or process I am missing?

1 Like

You can ssh in via the terminal on your computer, or an application like PuTTy on windows, but the easiest way is via the web interface Terminal page.

Yeah, we’ve hidden several pages by default now since most users won’t need to use them. You can show them again by turning on Pirate Mode from the settings :slight_smile:

3 Likes

Thank you for those tips! Great to have access to those features. I am still having issues with getting my position hold to work. Now when I copied that code I listed above and ran it in the web terminal, it says it was already used.


So I went to the available services to make sure the DVL Service is there, which it is.

When I check out the DVL Water-linked page, it seems to be setup the same exact way it is shown on the integration page. And it says it is running. But the only thing is I’m not sure if I need to pinpoint new origin, I believe it is on default position, which is not near my location.

When I check out the page for the DVL software itself, which I have at 192.168.2.95. I can see that the position parameters of x and y and just increasing, even though I have ROV stationary so that seems to be problem. Is it not syncing with companion still or is this a separate issue?

1 Like

Note the symbol beside “velocity valid”.

1 Like

There is a section on the Beta implementation page (DVL Integration · GitBook) here saying I need to have these parameters. How and where do I implement these parameters? I am still using new beta companion (beta.15).


You can set vehicle parameters in the Parameters page of QGroundControl :slight_smile: