Home        Store        Learn        Blog

Water Linked DVL A50 Support

Me and @arend have been testing the DVL in our test tank last few days. We have some problems that the DVL driver restarting sometimes. The warning in QGC are “EFK3 IMU0, IMU1 stop aiding”.

Someone that have the same problem?

Hi Robin,
We bought and installed the WaterLinked DVL but we’re having stability issues - the ROV drifts, sometimes setting the thrusters to high speed, and sometimes oscillates wildly. We’ve played with all the Parameters/PID settings to try and de-sensitise it, doesn’t seem to work any better. We’re using QGC version 4.0.1 and companion software 0.0.22.
Any help would be appreciated - would be good to know what settings to use:
AHRS_EKF_TYPE 3
VISO__TYPE 1
EK3_ENABLE 1
EK3_GPS_TYPE 0

PID Tuning:
PSC_POSXY_P: 3
PSC_VELXY_P: 6
PSC_VELXY_D: 1

thanks
Rich

1 Like

I haven’t been able to get Companion to communicate with the DVL. on the Companion page http://192.168.2.2:2770/waterlinked, I see the DVL status change from Unable to talk to DVL service > Looking for Waterlinked DVL-A50 (…192.168.2.95) > Waiting for vehicle


Hi @gcelec,

Try changing SERIAL0_PROTOCOL to Mavlink2 and restarting the ROV. The DVL driver is using mavlink2rest and for now it requires Mavlink2.

Thanks @williangalvani The Status has changed to ‘Running’.
I’ll get the vehicle in the tank and see what happens!

1 Like

BR2 is in the tank - which flight mode will gave station keeping? Stabilize, Depth hold and Acro are the only options that hold.

Make sure you have these parameters set properly:

Use ekf3 for the odometry support

AHRS_EKF_TYPE 3
EK2_ENABLE 0

Enable odometry support

EK3_ENABLE 1
VISO_TYPE 1

Disable external gps in ekf3

EK3_GPS_TYPE 3

Suggested gains

PSC_POSXY_P 2.5
PSC_POSZ_P  1.0
PSC_VELXY_D 0.8
PSC_VELXY_I 0.5
PSC_VELXY_P 5.0
PSC_VELZ_P  5.0

You should hear something like “Ekf3 started fusing odometry” when the ekf accepts the dvl data, then you can switch to position hold.

I’ve confirmed all the parameters are set as you suggested, but I’m not getting the “EKF3 starting fusing odometery” message. On the diagnostic page of the DVL all the beams are ticked green.

What Ardusub version are you running? That is not in a stable version yet. I suggest you use the Beta 4.1

Thanks @jwalser & @williangalvani -


Companion version Version: 0.0.21-30-g5cafdde
ArduSub Version: 4.1.0
2020-12-03 DVL.params (24.3 KB)

@richard-rickett Did you have success with this in the end?

Still working through it, Paul. We had a faulty unit, exchanged it - apparently now we can’t get the Pi to talk to the DVL, doesn’t seem to recognise the IP address. I’m a novice, but will try and have a look this week.

Update: yup, tested fine in the water.

Fix:
The Ardusub documentation says start at builds 0.0.22 or 0.0.23 and then do the update to the DVL branch. We kept getting the Water Linked tab in the companion web interface, but we couldn’t enter an IP address for the DVL - we got the spinning wheel of despondency. In addition, we couldn’t see the DVL listed under Active Services in the System tab.

Fixed now - for other users: if you have the same problem, log onto the pi (http://192.168.2.2:8088/), navigate to \companion\services\waterlinked\dvl-a50 and run pip3 install . --user (note the space between install and . and the space between --user, and note that it’s two minus signs before user). Let that run, reboot and fixes the problem. Kudos to @williangalvani . Hopefully it’ll get incorporated in a new build. Now to see how well the DVL works in the field.
@wlkh for info !

1 Like