Water Linked DVL A50 Support

Hi @williangalvani - no worries - I know how busy things get and appreciate your help. Here’s what I’ve done this morning:

Now Companion doesn’t recognize the DVL at http://192.168.2.2:2770/waterlinked and it’s not listed as an active service ( I did have those previously).
DVL IP address settings are the same as previously.

I have the same issue installing it from git. Orientation buttons and nothing works. Im

Im updated it from 0.0.28 → DVL

Ardusube 4.1.0 beta.

I have also tried to downgrade to 0.0.23 with same result.

Get this error when i try to start it manualy
pi@rov:~ $ ./companion/services/waterlinked/dvl-a50/main.py
Traceback (most recent call last):
File “./companion/services/waterlinked/dvl-a50/main.py”, line 7, in
from dvl import DvlDriver
File “/home/pi/companion/services/waterlinked/dvl-a50/dvl.py”, line 6, in
from mavlink2resthelper import Mavlink2RestHelper
File “/home/pi/companion/services/waterlinked/dvl-a50/mavlink2resthelper.py”, line 1, in
from companionhelper import request, post
File “/home/pi/companion/services/waterlinked/dvl-a50/companionhelper.py”, line 2, in
import requests
ModuleNotFoundError: No module named ‘requests’

1 Like

I’ve been holding off on upgrading until I know I have time to fix bugs.

There is a conversation in this thread about the affects of upgrading to Companion 0.0.28

I installed the DVL service according to “option 1” from this link
https://www.ardusub.com/developers/dvl-integration.html

Then I upgrade from 0.0.24-15-g33651de to 0.0.28-14-gee0a5df from git section selecting DVL according to “option 2”. This seems to worked perfectly. It connected with no problems.

1 Like

Hi,i have a waterlinked dvl a-50,but when integrated with bluerov,I am using ARDUSUB version 4.1.0,The position_hold mode works, but the system says the depth sensor is not connected, does anyone know why this is.

Hi @octopus,

Thank you,very cool! Everything work well now !!!

1 Like

Hello,

I am using the new beta companion and currently updated to beta.15. I am trying to integrate the DVL to it but am having difficulties. I saw the page on the docker implementation saying I need to ssh into the raspberry and run code, but I do not know how to do so. Is that through the companion software itself? If so where?


Also At the end of description it says configurations steps can be found through “available services” But I do not see that tab anymore on my software.

I do have access to the DVL separately through static IP I set to what it recommends in integration page. But from there I do not believe is connected to the companion software. Is there any other step or process I am missing?

2 Likes

You can ssh in via the terminal on your computer, or an application like PuTTy on windows, but the easiest way is via the web interface Terminal page.

Yeah, we’ve hidden several pages by default now since most users won’t need to use them. You can show them again by turning on Pirate Mode from the settings :slight_smile:

3 Likes

Thank you for those tips! Great to have access to those features. I am still having issues with getting my position hold to work. Now when I copied that code I listed above and ran it in the web terminal, it says it was already used.


So I went to the available services to make sure the DVL Service is there, which it is.

When I check out the DVL Water-linked page, it seems to be setup the same exact way it is shown on the integration page. And it says it is running. But the only thing is I’m not sure if I need to pinpoint new origin, I believe it is on default position, which is not near my location.

When I check out the page for the DVL software itself, which I have at 192.168.2.95. I can see that the position parameters of x and y and just increasing, even though I have ROV stationary so that seems to be problem. Is it not syncing with companion still or is this a separate issue?

1 Like

Note the symbol beside “velocity valid”.

1 Like

There is a section on the Beta implementation page (DVL Integration · GitBook) here saying I need to have these parameters. How and where do I implement these parameters? I am still using new beta companion (beta.15).


You can set vehicle parameters in the Parameters page of QGroundControl :slight_smile:

@EliotBR A follow up to what I was asking about before. I am integrating a new DVL to another BROV using the new BlueOS “Companion”. I went through all steps to get it working and does. But when updating the parameters listed above, three of them do not appear at all, so I cannot update them. These are the parameters in question:
image
Do you know what these do and where I can find them? Do they go with new BlueOS? I think important because it seemed I couldn’t get position hold to work.

Hi @Jnyberg ,

Make sure you are using the latest Ardusub 4.1.0 beta. 4.0 doesn’t support DVLs.

1 Like

Thank you for that. I updated to 4.1 beta and got the DVL connected. Now when I connect to ROV, the DVL and Ping 360 Sonar ae working, but position hold is still acting up and depth hold is not working at all. When trying to use position hold the sub starts rotating around. When I try to use depth hold, QGroundControl says that the depth sensor is not connected. Here is the error message for that:
image

When looking at the depth on the viewer, it is not changing at all either. The depth is titled as “Depth” but is actually registered under “altitude tracker”. Here i what that looks like:

Any insight at what I should do from here?

Can you confirm that BARO_PROBE_EXT is set to 768?

If it’s not fixed by the depth sensor parameter, please confirm that the DVL has a good lock when attempting position hold. If there’s a good lock but it’s still not working, or working poorly, then it would likely be helpful if you can share a log :slight_smile:

Yeah, Vehicle/AltitudeRelative works correctly for me for the depth sensor :slight_smile:

In addition to Eliot’s points, note that “stopped aiding” means the dvl stopped sending valid data. This probably means the dvl doesn’t have a good bottom lock.

1 Like

Thank you that parameter seemed to be the problem!

2 Likes

For future reference, I was wondering if there is a new DVL Integration instruction page for the new BlueOS companion. I know there is this instruction page for the old companion (DVL Integration · GitBook and Networking - Documentation), but that doesn’t cover all steps needed to get the DVL working with new BlueOS, and it would be a lot easier to reference if I had a new one. I tried looking around here on the forum page but couldn’t seem to find one.