Home        Store        Learn        Blog

Waiting for Video & Lenovo Tiny

A Lenovo Tiny M910q i5 was purchased as the topside computer. It was setup and QgroundControl and LibreOffice (to take notes) were installed. It was connected by Ethernet to the RaspberryPi companion (no Pixhawk or FathomX).

Start QgroundControl. I get “Waiting for Video”
Remove the Ethernet from the Lenovo M910q and plug it into my HP 8870w i7 laptop. The camera video is working. There is nothing wrong with the RaspberryPi 3B setup.

Check the Internet I.P. address:
In the search box type cmd enter, type ipconfig enter to check the I.P. It was changed to give the screen below.
(Google setting I.P. Address Win10 if it is not 192.168.2.1 and 255.255.255.0 as below)
image

Confirm communications between Win10 and RaspberryPi at http://192.168.2.2:2770/ camera
I can see the camera and make adjustments. Lower the resolution as suggested, no improvement.
Test bandwidth of Rpi at 192.168.2.2:2770/network
Upload results: 91.938 Mbps
Download results: 81.549 Mbps

This confirms communications between the two computers. The problem is in the M910q setup.

In the QGC click the ‘Q’ icon, then Applications settings, then the ‘General Settings’ tab. Drag the screen up to see the options for ‘Autoconnect to:’, make sure the UDP option is checked. OK.
Note: the slider on the right does not work, drag the screen.
Drag the screen up to check the video settings. The video source should be set to UDP video, and the port should be 5600. Change and re-start QGC. OK

I had tried turning off Defender but there is no single button to do this. In retrospect I should have made sure it was off.
I tried to find how to allow QGC through Windows Defender firewall. There are various methods that do not agree with Win10 screens. This was the result which did not look right and I could not change it. I also could not find my way back to this window.
image

I checked the rest of the troubleshooting.
Disable/re-enable the network interface, Reboot.
Try launching QGC from each of the three shortcuts.
None of this helped.

The instructions say for using Windows Defender :
In the Start bar, enter/select: Firewall & Network Protection (System Settings).
Scroll to and select the option: Allow an app through firewall .
Select QGroundControl and change the Access selector to Allow.
Programs are listed in alphabetical order by description (not filename). You’ll find QGC under O: Open source ground control app provided by QGroundControl dev team

The problem is that many steps are left out for someone used to Win7. The correct instructions should be:
Start>Settings>Update and Security>Windows Security>Firewall and Network Protection>Allow an App Through Firewall.
This time it worked and only a single line with both boxes checked was shown.

Success and both the Camera and Ping Sonar are displayed. I am ready to try the Pixhawk which should arrive later this week.
I hope these troubleshooting steps might help anyone with similar problems.

1 Like

I have a lonovo Computer also, I found that on my computer Qgroundcontrol will only work on 1 of the 3 USB ports on my computer , if i use the other 2 all i get is a Waiting for Video also which never happens. Try changing USB ports. Yet my Game controller and other devices work fine on all 3 ports.

Hi Peter, thanks for this :slight_smile:

I’ve moved your post to the QGroundControl category, and tagged it as a guide so others can find it more easily.

Jim;
I don’t understand. The QGC runs on the surface computer which talks to the ROV on the Ethernet port.
Without the tether the Companion (Pi) still connects to the Ethernet port of your Surface computer. USB is not used. My camera works on all four of the Companion RaspberryPi USB ports if that is what you mean.

A caution to anyone thinking of the Lenovo Tiny computers; it only has a Display Port connector. You will need a Display Port to HDMI adapter cable (about $12 Canadian, adapters are cheaper).
You could use a monitor with a Display Port but that could be a problem if you want to use the monitor on something else. I understand HDMI to Display port adapters are harder to find. I abandoned the idea of using the Lenovo monitor with the Tiny slot.

I don’t see any problems yet using the Tiny. It runs very cool and I will investigate running it off an inverter from the boat battery. I am also purchased a monitor with Brightness, Wall mount, and power supply in mind. It all has to run off the boat battery.

1 Like

Peter
Sounds like you got the problem fixed, When i meant by the usb cable, i have the Fathom X
box which connects to the tether which connects to the ROV, The fathom X Box connects to my Laptop through a USB port. Sounds like we have two different Setups.

Good luck