Home        Store        Docs        Blog

Waiting for Vehicle Connection


(RC) #1

After rebuilding laptop control computer to boot win10 from SSD, unable to gain control of ROV. Using Q Ground Control 3.2.4, Rev4, “Waiting for Vehicle Connection” displayed in red at top of QGC display. Video display is OK and able to ping 192.168.2.1 (ROV). PixHawk I/O B/E LED is steady orange suggesting something is wrong. What happened?


(Patrick José Pereira) #2

Hi,

Are you running the last version of companion ?
You should ping 192.168.2.2, the final .1 is your topside computer.
Is it possible to access http://192.168.2.2:2770 ?


(Jacob) #3

Please verify your network configuration and subnet mask is:

255.255.255.0

Try also the tips here.

Please take a video of the lights on the pixhawk during start-up (when power is applied) if you believe it is at fault.


(RC) #4

Jacob, Twice I tried to send video, but video file was too large to send. In a nut shell, ROV pings just fine at 192.168.2.2. Video at Q Ground Control PC is outstanding. No issues, so far. PixHawk LED indicator lights are as follows: Both power LEDs lit steady green, I/O LED lit Steady Orange, and I/O ACT heartbeat blinking 2 per second Blue. ROV beeping at 4 second interval.

QGround Control displays “Waiting for Vehicle Connection”.


(RC) #5

Jacob, Attempting to log into raspberry pi on BlueROV as per your instructions: “Check that mavproxy is running on the pi. Log into the Pi via ssh or PuTTY, and type.”

No instruction set on how to log into raspberry pi. Unknown Password, unknown username. raspberry and pi, the default username and password does not work. Unable to verify that mavproxy is running on the pi.


(Jacob) #6

Ok thank you for pointing this out, I will correct it now.

You can also get a terminal in a web browser at http://192.168.2.2:8088

From what you have indicated, it does sound like your autopilot has died. You may contact support@bluerobotics.com for a replacement at no cost.


(RC) #7

Jacob,

Thank you very much for your assistance. I have since replaced the autopilot and that appears to have corrected the problems I had. You should be receiving the old PixHawk sometime next week.

I have need for one last assist.

The Xbox controller needs some fine tuning. When I purchased the ROV last year, Jeff Conger down here in San Diego gave me an assist. He was able to tweek the joystick and get the controls functioning. I would like to figure out what he did. I need to repeat what he did.

I got the compass to calibrate OK. The accelerometer calibrated, but was tilted 90 degrees. I got the horizon close to level by changing the setting to 90 degrees/Roll. Is this correct?
Now I am in need of setting the Joystick controls. Attached is three pages of drawings, showing what happens with my joystick. Jeff was able to correct this somehow in about 30 minutes. How do I correct the joystick settings?
I can see how to change the function of each button, but how do I reverse the direction of a particular button?
I look forward to hearing from you.

Very Respectfully,

Richard Merriman


(Jacob) #8

Hi Richard, I cannot take a guess as to what Jeff did. Can you describe your problem with the joystick right now? There is nothing attached here.

Everything that you need to do to get set up is described step by step in our software setup instructions. Please follow these instructions carefully and let me know if you still have any problems. You will find a note about the Roll90 setting in there.

What do you mean to reverse the direction of a button?


(RC) #9

Jacob,

For the joystick control buttons, when I push the button to the left, QGround Control shows that I pushed it to the left. Wait,……

Software setup instructions! Perfect! That’s what I was looking for. Cool. Thanks. Will check back with you later.

V/r

Richard


(RC) #10

Jacob,

I was able to correct the joystick issues by reversing 1, 2, & 6 thrusters direction. All is/was good. I now have an issue with the Fathom-X Tether Interface, rev 2 board. The micro USB power connection just fell off. WTF? I will need a new Fathom-X Tether Interface board. Please call me.

V/r

JV


(Jacob) #11

Hi @JulesVerne I’m glad you have figured it out. Rusty has responded to your complaint about the Fathom X in the other other thread.