Home        Store        Docs        Blog

Waiting for vehicle connection using mac, can see video and ssh, but cannot connect to vehicle


(Christian) #1

I am trying to get qgroundController to connect with the vehicle but it doesn’t connect. I really appreciate your help. I am trying to have this working for a long time and I cannot : (

I am using mac Sierra version 10.12.6

  1. So the hardware is the one from BlueRov v1, but just reconfigured the motors position like BlueRov 2
  2. I downloaded the new version of QgroundController and new raspberrypi image from here:

https://www.ardusub.com/getting-started/installation.html

  1. I use an a USB to Ethernet adaptor. I did all the network configuration mentioned here: http://docs.bluerobotics.com/brov2/software-setup/#software-introduction.
    I entered 192.168.2.1 for the IP Address and 255.255.255.0 (yes not 255.255.0.0)

I turn off the firewall.
I can ssh to raspberry pi, works perfect
I can see the video, works perfect
I cannot connect to the vehicle. Only If I use the usb por connected to pixhawk and laptop, I can connect to the vehicle.

If I do
nc -ul 192.168.2.1 14550
I get:
nc: Can’t assign requested address

If I do ifconfig I get

…blah blah…
bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
options=3<RXCSUM,TXCSUM>
ether ae:bc:32:ec:ad:64
inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
inet6 fe80::acbc:32ff:feec:ad64%bridge100 prefixlen 64 scopeid 0xd
Configuration:
id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
ipfilter disabled flags 0x2
member: en6 flags=3<LEARNING,DISCOVER>
ifmaxaddr 0 port 12 priority 0 path cost 0
nd6 options=201<PERFORMNUD,DAD>
media: autoselect
status: active

I followed every similar topic in the forum, but can’t make it work.

I really really appreciate your help.

Thank you.


(Jacob) #2

How about https://www.ardusub.com/troubleshooting/troubleshooting.html#no-telemetry-no-pixhawk-connection?


(Christian) #3

Thanks for helping.

  1. I do have udp checked per your link.

  2. Yes I can ping it
    PING 192.168.2.2 (192.168.2.2): 56 data bytes
    64 bytes from 192.168.2.2: icmp_seq=0 ttl=64 time=2.449 ms
    64 bytes from 192.168.2.2: icmp_seq=1 ttl=64 time=0.488 ms
    64 bytes from 192.168.2.2: icmp_seq=2 ttl=64 time=0.449 ms
    64 bytes from 192.168.2.2: icmp_seq=3 ttl=64 time=0.469 ms
    64 bytes from 192.168.2.2: icmp_seq=4 ttl=64 time=0.502 ms

3)firewall is turned off, and static ip is 192.168.2.1 per instructions I mentioned before.

  1. Ethernet jack activity is working, blinking green.

  2. screen -r mavproxy
    There is no screen to be resumed matching mavproxy.

Then I restart mavproxy

pi@raspberrypi:~ $ ~/companion/scripts/start_mavproxy_telem_splitter.sh
Connect /dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v2.x_0-if00,115200 source_system=200
Failed to connect to /dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v2.x_0-if00,115200 : [Errno 2] could not open port /dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v2.x_0-if00: [Errno 2] No such file or directory: ‘/dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v2.x_0-if00’

The cable is connected from pin 4 and pin 5 from raspberry to the usb on the top of pikhawk (not the micro usb of the pikhawk)

However, how should the pikhawk be connected to raspberry? from the micro usb port on the side of the pikhawk to an usb port on the raspberry or the micro usb port of the raspberry.

If I connect from the micro usb pikhawk (on the side) to the big usb on the raspberry (not the micro) it works. Is this config correct ?
(I then power the raspberry from to the micro usb, because I run out of battery, is it ok to use it this way for testing?).

Thanks,


(Jacob) #4

The image is set up for usb.
Connect the autopilot via usb.


(Christian) #5

Thanks (its unfortunately that this is not clearly specified on the doc). Your link really helped!!! Thank you very much !!!