Home        Store        Docs        Blog

Waf ArduSub build not working - which board?


(Patrick José Pereira) #21

Hi,

Thank you for pointing that, since sub-3.5 is a bit old, I would recommend to run the last version of this script.

bash <(curl -s https://raw.githubusercontent.com/ArduPilot/ardupilot/2fe3535fd81434dac4146694ed38435e7ed335ec/Tools/scripts/install-prereqs-ubuntu.sh)

Let me know if this works for you.


(Sakib Ahmed) #22

skb@DESKTOP-02QR8Q5:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic


(Sakib Ahmed) #23

so it finally compiled on WSL(Ubuntu16) . Unfortunately, none of the instruction Gitbook completely worked.
as you would see in my log. arm-none-eabi-g++ and ubuntu18 seems to be the problem.
https://codeshare.io/arYD6z
Thanks.


(Patrick José Pereira) #24

Hi,

Glad that the prereqs script worked for you, let us know if you need any further assistance.
You can read more about ArduSub build instructions here: https://www.ardusub.com/developers/developers.html
Ardupilot documentation sometimes can fail to be complete or updated, so it’s better to follow ArduSub website.