Home        Store        Docs        Blog

Trouble uploading ArduSub build


(Richard) #1

Hi All
I’m having some trouble uploading a custom ArduSub build to my pixhawk. I added a custom frame configuration to the latest stable ArduSub version and built using Waf as described here:
https://www.ardusub.com/developers/developers.html
I have my pixhawk connected directly via USB and the upload step stalls here:


Multiple unplugging and re-plugging cycles don’t improve the situation.
I’d be happy to upload the new build via the companion Pi, but I’m a little puzzled as to exactly where this new build file ended up… I can’t find a file named ArduSub-v2.px4, but I do see a freshly-created ardusub.px4 in /ardupilot/build/px4-v2/bin/. Same thing?


(Jacob) #2

Yes, ArduSub-v2.px4 is the result of building with make instead of waf.

The upload program is looking for a usb device plugged in to the computer. Try this:

$ ls /dev/serial/by-id
usb-3D_Robotics_PX4_FMU_v2.x_0-if00

Does your computer detect the device plugged in? Your usb cable might have only power lines, no data lines.


(Richard) #3

There seems to be no /serial in my /dev directory… hmm.
$ ls /dev/disk/by-id
works fine. No serial directory at all… lots of tty* values there in /dev of course. Tried a couple of different USB cables in case one of them was some bullcrap charge-only cable, same result.


(Jacob) #4

Something is physically broken then.


(Richard) #5

Very weird! Guess I’ll go the companion-update route.


(Jacob) #6

Taking the same autopilot and cable on the pi, does it come up in /dev/serial/by-id?


(Richard) #7

Yes, it shows up on the pi, which has /serial and /serial1 directories in its /dev dir that my main computer doesn’t have.