View LAT LONG coordinates Cerulean Mark II OSD

I recently got the Cerulean Mark II ROV locator. Connections and settings performed as per manual. QGC sees the ROV and its movements on the map. But I can’t see the Lat and Long coordinates on the screen display.


It is important for me for my work to record videos with coordinates as subtitles. I thought it might be an easy thing but it’s like the ROVL coordinates get stuck somewhere


I also tried UDP 14401 as suggested in CeruleanTraker

2024-06-24_164525

I did all the possible tests with GPRMC and GPGGA output

I also tried in BlueOS with Cockpit but nothing, the coordinates don’t arrive

Help Please

Change the output location to 192.168.2.2 : 27000

Hi @sigane17 ,
Do you have a Cerulean DVL attached to the ROV? If so, and you are using the ROV Locator with CeruleanTracker simultaneously, ensure that the navigation input sources do not conflict.

  1. If you are using the DVL + ROV Locator (combined) and want CeruleanTracker to be your main navigation source, make sure to disable the DVL-Cerulean BlueOS extension. Ensure that all input sensors are detected by CeruleanTracker, such as the Topside GPS, ROVL RX, and DVL. In the output tab, check the combined ROVL + DVL or filtered ROVL option and check the output messages (GPRMC). Finally, send the data to the ROV at 192.168.2.2:27000. Additionally, you need to edit the ArduSub parameter GPS_TYPE to MAV (14). This will display the ROV position in latitude and longitude coordinates within QGroundControl (QGC).
    image

  2. if you are using DVL + ROV Locator (separately) and want DVL to be your main navigation source and use CeruleanTracker with ROV Locator to be your sidekick to show ROV Coordinates. make sure to enable dvl-cerulean BlueOS extension and follow this step, and create a new NMEA socket inside BlueOS for example UDP:27001
    image
    open ceruleantracker checked the output messages (GPGGA), send to ROV 192.168.2.2 : 27001, finally edit the ardusub parameter GPS_TYPE to MAV (14)
    image

  3. if you are using ROV Locator(only), ensure NMEA injector address inside blueos are 192.168.2.2:27000 same with cerulean tracker output messages, and don’t forget to change ardusub parameter GPS_TYPE to MAV(14)
    image

I also tried UDP 14401 as suggested in CeruleanTraker

The port you are referring to is not for the ROV’s GPS input; it is meant for the QGC GPS input. Consequently, the QGC GPS coordinates will correspond to the maps rather than the ROV’s actual location.

Hi @ryan354 -
Can you elaborate on what extension you’re referring to here? Do you mean the default behavior of the Cerulean Tracker 650, where it sends the appropriate messages by default to the Mavlink2Rest interface? There is no specific DVL-Cerulean extension that I’m aware of otherwise… Are you suggesting the default behavior of the DVL should be disabled for option (1)?
Thanks!

Hi @tony-white
I apologize if I am mistaken; please feel free to correct me. I was using Cerulean DVL-75 with cerulean-dvl-blueosextension cerulean-dvl-blueos reference

My apologies @ryan354 - I was thinking of the Tracker 650, I’ve not used the DVL-75.

I am not an expert but I have succeeded as patience. In Pirate Mode all a thing …

Thanks

BlueOS has an NMEA Injector page, which is available when you have Pirate Mode enabled.

Because in Cockpit I don’t see the coordinates. I would like to test it as soon as possible.
Another request, I can only download the tracking in .shp or .kml format

I believe you should be able to configure a Very Generic Indicator to show them, via the GPS_RAW_INT message (or possibly GPS_INPUT), or GLOBAL_POSITION_INT if the vehicle is managing to estimate its position.

Every time restart the ROV it loses its configuration

Hi @sigane17 -
This may be happening if you’re not on the latest version of BlueOS, and if you haven’t updated the bootstrap after updating (yellow button.) Once you’ve done that things should stay consistent!

Just adding that the grey header bar saying “DISCONNECTED” at the top means your computer is not connected to BlueOS, so it can’t check what is or isn’t configured. I’d suggest confirming that your vehicle is on and has had enough time to start up, as well as checking your tether connection and/or your computer’s network configuration if it’s still not connecting.

That said, the “NMEA sockets are not persistent” warning does indicate your last connection to BlueOS was on an old version, so as Tony suggested you might need to update or switch your BlueOS version (we recommend the latest stable, which is currently 1.2.6), and if your bootstrap version has not been updated since a 1.1 release then you should also update that :slight_smile: