Vehicle setup/BlueOS issues

Hi there, going through my vehicle setup, and I feel like I am missing something.

To preface, I tried going to vehicle setup to load default parameters (Blueboat120.PARAMS) and initially they appear to write, but then I get the error failed to write some parameters. Please restart and try again (which I have attempted) to no luck.

I am following the blueboat software setup guide and am running into some issues. I have paired my base station, and connected to the basestation 2.4Ghz wifi. I am at the stage where I am accessing BlueOS and I have connected to the basestation wifi in BlueOS, I have wifi but no internet but thats normal cause its a local connection?

Following the steps I search for BlueOS updates and I look for autopilot firmware updates (currently I am on 4.2.3 (STABLE) I get no data available and get the error Autopilot Manager (Firmware_fetch_fail error:Request failed with status code 500)

Question 1:
I am wondering do I need an internet connection at this point to get access to firmware updates (if yes then how? With a wifi adapter/dongle?)or am I simply on the latest update? The error message makes me think its the former?

I continued with the software setup and attempt to calibrate the powerSwitch, when I open the extensions tab, there aren’t any present like in the startup guide? And I also get this error?
“Kraken service
cannot connect to host ssl:default [Temporary failure in name resolution] [errno-3]Temporary failure in name resolution.”

I should be able to see these extensions present in the setup guide should I not?

All these errors right off the bat makes me thing I’ve done a silly mistake and set something up wrong? I’m hoping someone can set me straight? Im sorry for the wall of requests.
Thanks for all your help!

Hi @Alex_Whitworth

You do need an internet connection in order to get updates, yes! You can either bridge your computer’s WiFi with internet to the ethernet connection going to the BaseStation, or connect the Raspberry Pi WiFi to a network with internet access - WiFi icon in the upper right.
4.4.0 is the latest version of ArduRover.

You will only see extensions appear if you have an internet connection! Your screenshot shows that BlueOS is connected to WiFi, but it doesn’t have internet access (globe with slash going through it.)

Once connected to internet, please update BlueOS to 1.2 beta8 - enable pirate mode for this option to show up under BlueOS Version menu. If you’re still having issues when loading the default parameters, checkout this thread - if you flashed the BlueOS image yourself you need to add a lights.lua file.


Thanks soo much Tony!